Freedome on MacOS is very slow to connect

Hi, Freedome takes a very long time to establish connection in MacOS. I have to use open wlans at the moment so I'm using Freedome to have some security. When the wifi has connected, it takes some 3-5 minutes for Freedome to connect which is frustrating. To my understanding it should happen in seconds. This happens with different wlans and also with cell phone hotspot.

This is on Macbook Pro 13" 2018 and MacOS Catalina (10.15.2, up to date). Freedome version is 2.32.6293.0, up to date.

Answers

  • JaimsJaims Posts: 340

    Hi @Igloo 

     

    Have you taken a look at this post here?

     

    We recommend you try to reinstall F-Secure Freedome and if it's still same, kindly try to flush DNS cache on the Mac and Enable the Killswitch then try again. 

     

    Here is how to check and enable automatic Killswitch.

    1. Open Freedome
    2. Click Settings

    The automatic killswitch is the 4th button under Connection & Status. If it is turned on,

    1. Click Allow connections to other devices in trusted networks
    2. Check the network you're currently connected to
    3. Click Save

    User-added image

  • Tommy600Tommy600 Posts: 17

    I have also had this issue on multiple systems. The issue for me seems to mainly occur after the Mac comes out of sleep. I am using a wired conneciton which has been added to the kill switch list. I find most of the time it is quicker to close Freedome and open it again, or turn off the VPN and turn it back on, but I am curious to know what the issue behind the problem is. Clearly there is an issue.

     

    For the moment I have turned the kill switch off to see if this makes a difference to the problem. 

  • Tommy600Tommy600 Posts: 17

    I noticed the issue does not happen if the killswitch option is off. I get a fatal error 50% of the time after my mac comes out of sleep with the kill switch on.

  • Tommy600Tommy600 Posts: 17

    I had another few fatal errors after coming out of sleep, I used the option to send a crash report to F-secure so hopefully this will show you what happned?

  • IglooIgloo Posts: 2

    Hi@Jaims I'm already in Catalina and I'm not seeing anything else relevant in the post you linked. The network speed is not an issue, this happens also with very fast broadband connections.

    I'll try to flush the DNS cache. I don't understand the last points of your reply. I have the killswitch active but I'm not going to allow connections to other devices in open wlans because disallowing them is the reason to use Freedome in the first place.

  • Tommy600Tommy600 Posts: 17

    I have discovered having power nap enabled seems to cause issues. I have turned this off and Freedome now connects without issue even after coming out of sleep.

Sign In or Register to comment.