Cannot access local ip network address after upgrading to Android 10

I have onePlus 6T

and after upgrading from Android version 9 to Android version 10 (OxygenOs 10.3.0)

I cannot anymore access the local network, either with ip address or hostnames

 

I have web service running on xxx.xxx.xxx.x:xxxx and cannot access when Freedome is on


From Freedome - settings - Trusted Wi-Fi networks, my SSID is set as trusted.

Also from app setting from under android settings, the Freedome has location permission and no restrictions.

 

Freedome version 2.5.14.8453

Comments

  • bryan441bryan441 Posts: 38
    Did you check after restarting your Router?

    Bryan Anderson

  • Try to restart your device. 

  • thxythxy Posts: 3

    I have rebooted the router couple of times between tests, did not help.

     

    The local ip address connection works on android 9, and on my windows machine fine

    but with Android 10, it doesn't

  • bryan441bryan441 Posts: 38
    Please try to uninstall and reinstall back your Freedome apps to verify the issue.

    Bryan Anderson

  • thxythxy Posts: 3

    Uninstalling and then reinstalling did not help, still does not connect

    I also reseleced my SSID as the Trusted Wi-Fi networks

     

    If I go to  "Apps bypassing VPN" and select the browser, then I can connect to local ip networks addresses (natuyrally as it bypassing the freedome), but the soonest I deselect it, it won't connect anymore

     

    Tried this also with the latest Freedome 2.5.15.8592

     

    bryan441
  • bryan441bryan441 Posts: 38
    I am sorry to say that i don't understand. You should contact with https://www.f-secure.com/en/home/support/contact

    Bryan Anderson

  • JaimsJaims Posts: 392 Moderator

    Hi @thxy 

     

    Thank you for reaching out to us. 

     

    The reason why you are unable to access your local network is because Android version 10 OS and later require you to select Trusted Wi-Fi networks from FREEDOME Settings.
     
    If you have previously denied the permission to use "Trusted Wi-Fi networks" feature in FREEDOME, try to use the feature again so as to trigger the prompt. You may have to start the configuration all from the start by going to your Android Settings and reset the permission from there.

     

    Kindly have a look at this KB article here

    LakshDawidFS
This discussion has been closed.