[BUG] Freedome doesn't reconnect automatically after lost connection - temp fix: give us a reconnect

R8R8 Posts: 10 New Member

Many times Freedome loses its connection, but it doesn't detect that itself. I have to discover it myself, when I open a new page that doesn't load. Losing the connection is bad service, and this happens too often. Not detecting this is a bug.

 

First I want a reconnect option in the menu, so I don't have to turn the service off, then on, to reconnect. This is a no-brainer and should be easy to implement.

 

Second Freedome should detect this itself, and reconnect immediately, or show at least a blinking icon to make clear that the connection is lost.

 

Third: I've noticed that there are months when the service is bad. The connection gets lost many times, daily more than once. This happens a lot on my Mac, but apparently not on my Android phone. I have no idea if this a software problem for the mac, or a service problem with the connecting server.

Comments

  • SethuSethu Posts: 644 Moderator

    Hi @R8 

     

    For Mac OS, please check if there is proxies enabled in Proxy Settings. If its enabled,  you need to disable the proxy Settings to see if that solve the issue.

     

    Open System Preferences and click on Network. On the left-hand side, make sure to select the connected or active network connection. You can have different proxy settings for each type of network connection.

     

    At the bottom, click on the Advanced button. Click on the Proxies tab and you’ll see a bunch of different protocols you can configure. You can now untick to disable the proxy if any.

     

    If there is no proxy enabled, please provide us some more descriptive information about Freedome reconnecting issue.

     

    May I know what virtual location you are using? have you tried to select with different virtual location?

     

    Could you please provide us the website URL that are not loading? and are you using any other anti-virus on same mac OS?

     

     

     

     

  • R8R8 Posts: 10 New Member

    I don't use proxies, never have used them, and I did check it to be 100% sure. Using F-Secure Antivirus. Wifi is strong, AP in sight and I don't see the wifi signal getting lost ever.

     

    Website URLs: when a page doesn't load, it can have several reasons. The website could be offline or slow, my internet connection could be slow, and the VPN could be offline. When my radio (other device) is still playing, internet is working. When I try various different domains, it is clear that the problem is the VPN. When I disable and enable, all works again. Another sign that the problem is the VPN.

     

    Location is Amsterdam. I'll try Brussels.... Tried Brussels - same problem!

     

    Does Freedome have logs that I can view?

  • SethuSethu Posts: 644 Moderator

    Hello @R8 

     

    May I ask you to enable the killswitch feature on your Mac machine?


    Freedome > Settings > Enable killswitch > Allow connections to other devices in trusted networks > Select his "network adapter name"

     

    On Mac, the killswitch feature is turned OFF by default. When FREEDOME is in the "connecting..." state, the network traffic outside the VPN tunnel will not be blocked until the connection is established. When the killswitch is turned on, it will block the network traffic even if the reconnection attempts are unsuccessful.

     

    You can refer this KB article to know generate logfile for Freedome on Desktop machine, but the logfile analysis done by our F-Secure Support team.

     

     

     

  • R8R8 Posts: 10 New Member
    The killswitch is enabled and has been since long.
  • SethuSethu Posts: 644 Moderator

    Hello @R8 

     

    If you have already enabled the killswitch but the issue still reproduce, the next course clearing DNS cache to see if that solve the issue. Typically, your DNS cache stores the locations (IP addresses) of web servers that contain web pages which you have recently viewed. If the location of the web server changes before the entry in your DNS cache updates, you can no longer access the site. After you clear your DNS cache, your computer will query nameservers for the new DNS information.

     

    Click here to know how to reset DNS cache on your Mac OS X.

     

    Should the situation not improve, the best advise for you to contact our Support team for further assistance. 

     

     

This discussion has been closed.