Freedome VPN subscription not recognizing Family Sharing on iCloud/iOS

So a few years back, we purchased Freedome VPN for our iOS devices (iPhone, iPad, etc.).

So far, it's worked very well, up until today.

 

Today, I went off the VPN and found that I was unable to go back on and I now required a subscription. I was then told that we actually had an automatic renewal for the service and it was purchased over a month ago. It even turned out that my phone wasn't even the only device affected.

 

Several months ago, we actually split up into two other iCloud accounts and then put them into iCloud's Family Sharing as a central network (the original account still exists). As of today, only the device logged into the original iCloud account can be able to access the subscription. All the rest of our devices have been pretty much locked out.

 

Neither the "restore iTunes purchases" nor reinstalling the app has worked. Additionally, we even reported the issue to the iTunes/App Store, but they suggested that we contact the app developers.

 

The last thing I (or my family) want is to have to either purchase two other subscriptions or to just go back to using our one original iCloud account.

Comments

  • JaimsJaims Posts: 353

    Hi @mashup67 

     

    May I suggest that as the Organizer, reinstall Freedome VPN on your device first, then review the Family Sharing settings, reconfigure and readd your family members afresh. Preferrably, use a Mac just to ensure that you register your network as trusted by enabling the killswitch feature and see if that works. Kindly see the steps here.

     

    Also ensure every device has the latest version of Freedome VPN installed which is version 2.9.0.6838. In addtion, the purchase of F-Secure Freedome VPN must have been made from Apple Store and not from anywhere else for you to use this feature.

     

    Let us know if this helps.

This discussion has been closed.