No TAB to allow/deny websites

Has an update of F-secure changed how we allow or deny websites?

I cannot restrict anymore for my children as the TAB is not there anymore


Please can you help? I am on Windows computers


Many thanks

Best Answer

  • UkkoUkko Posts: 2,990 Superuser
    Accepted Answer



    Yes, thanks for your response!

    For me it sounds that entire "Browsing Protection / Family Rules" (Online Safety module) is not installed (is not activated).


    Because: "Allowed/Denied websites" is not visible under "Tools"; there are no any other indications of things like Family Rules (as an additional tab).


    I checked for last updates and it shows tonight at 20.47

    Could you check further (where list of installed updates is visible) by scrolling the settings screen or reading more where any strings about "Online Safety"  or anything else.

    In general, there should be strings like "F-Secure Hydra Update 2019-date" and other. Need to check whether all strings with status "Installed" or not. And, for example, anything about "Online Safety" as such.


    // later added:

    I tried to install F-Secure SAFE stable build and all is OK with Family Rules / Parental control.

    This module is still there. And list of allowed and denied websites too.


    Thus, something wrong with your installation. I could to recommend reinstallation - but it will completely and surely "clear" all exclusions (allowed and denied websites). Whereas, maybe, your situation is about temporary glitch and it is possible to return functionality with less impact.


    Perhaps, required module with pending status and need to restart system or somehow to trigger further installation of it. However, maybe certain environment is important there (for example, multiple user accounts or so; my check was only about generic set up).


    In addition - it is possible to reach their official support ( For example, chat. And to investigate this case a bit more (reasons, explanations, fixes, solutions).





  • UkkoUkko Posts: 2,990 Superuser



    It is strange a bit. There was not any update with such changes (probably).


    But could you provide more information:

    -- what is your current F-Secure solution and what is version?

    -- what did you mean by "TAB"?

    Is it "TAB" as "Tools" or it is "List of allowed / denied websites" button on Tools tab?

    -- did you try to restart system (in addition to "shutdown" / "turn on")? And what is the state of installed updates (rightclick F-Secure tray picture and 'Check updates' - then to check whether all modules with "installed" status or not).


    And maybe could you create / attach a screenshot about current state with place where such ability should be? Of course, with redacted/edited critical data and information on it.


    Sorry for my reply! Only as discussion between community users!



  • Hello Ukko


    Thank you for your message. I have checked the version, it says I am using F-Secure Safe 17.7


    By Tab, I mean that when I click on Tools (after opening F-secure on my pc) I used to have an option with Allowed/Denied websites where I could specify single sites. That option is now not visible and this has just been noticed (although remember using it less than 2 weeks ago)


    I checked for last updates and it shows tonight at 20.47


    Please see screenshot showing where the Option Allowed/Denied Tabs was located. 

    Many thanks



  • Dear Ukko


    I attach updates screenshot, all seems there

    I dont understand it as all worked fine till at least last week

    I will log a ticket with the support team in case

    Many thanks



  • I have removed F-secure and re-installed. All works fine now

    Thank you for your input! Much appreciated



This discussion has been closed.