Android 9 - Freedome stops ethernet connection

Hi,

I recently purchase a new android box with Android 9.  Ethernet worked fine.  Installed Freedome and F-Secure Safe and no ethernet possible.  Tried changing settings, rebooting, changed cables - impossible to connect to ethernet.  Returned the box as faulty.

Bought a differnet make of Android box with Android 9.  Box worked fine.  Ethernet working.  Installed just Freedome (No F-Secure Safe) and Ethernet impossible to connect.  Tried changing settings, rebooting, etc, etc.  But no success.

Grateful for your help.

Best Answer

  • SethuSethu Posts: 519
    Accepted Answer

    Hello @harry4 

     

    This is because of customized android OS running on your android box. F-Secure Freedome products do not official support Android TV box. Some of its components that Freedome requires are not part of your installation, namely the android VPN.

Answers

  • SethuSethu Posts: 519

    Hello @harry4 

     

    Please check if automatic killswitch is enabled. Here's how to check.

     

    1. Open Freedome
    2. Click Settings

     

    The automatic killswitch is the 4th button under Connection & Status. If it is turned on,


    1. Click Allow connections to other devices in trusted networks.
    2. Check the network you're currently connected to i.e ethernet
    3. Click Save

  • Hi, thanks for the response.

    I am not presented with the options you describe.  I open Freedome, click on settings, then under CONNECTION there are 3 items only:

    Trusted Wi-FI networks

    - Apps bypassing VPN

    - Automatic Killswitch

    Automatic Killswith has a button to click to activate or deactivate......

     

    That's it.  I am not given the option to "Allow connections to other devices in trusted networks"

    These are excatly the options I was given with the different make of Android 9 box I returned as possibley faulty.

    Thanks - please advise.

Sign In or Register to comment.