F-Secure Sage hangs on configuration step

I am trying to install f-secure safe on may Macbook Pro, MacOs Mojave 10.14.5


After I login and click continue it gets stuck showing "Just a Moment" on screen and a spinner keeps spinning for hours. I cannot finish setting it up. Please help...


  • Simon
    Simon Posts: 2,665 Superuser

    Have you got, or have you had, any other anti-virus software installed on the machine? 

  • Jaims
    Jaims Posts: 846 Former F-Secure Employee

    Hi @tzarsmango 


    In addition to @Simon please ensure that there is no other antivirus present on your Mac before attempting to install F-Secure SAFE. That could be the cause or even be a problem later if the installation finally goes through. 


    You may need to do a cleanup of previous SAFE installation attempts by using the removal tool. Click here to download and run the tool, then try to reinstall SAFE again. Also check your My F-Secure portal and ensure you have a valid license left. 




  • tzarsmango
    tzarsmango Posts: 3 New Member

    I tried the uninstal in the application folder and reinstalling. I also had Rapport installation and I removed it. I also tried the uninstall.zip in the link you've provided. Same result


    I have the latest MacOs updates 10.14.6 but still getting stuck in the license assignment step with Just a Moment message and infinite spinning... 

  • tzarsmango
    tzarsmango Posts: 3 New Member

    This Mac was shown in the license list, actually it showed up multiple times, once for each initialisation trial. I had to release licenses several times during my trials. But it was shown as broken/incomplete with an exclamation mark on it.


    I have sorted it now. What I did was: I logged in to my computer with another user acount and did the license initialisation with that user. After that when I returned to my user I could use F-Secure SAFE. 


    Thank you for your support.

This discussion has been closed.
Pricing & Product Info