Freedom stopped working

Rickl Posts: 3 New Member



Freedome subscription expired. I renewed and entered in the new activation code. Things have been working the last few months. This weekend I got a message that my code was expired, but the Subscription screen showed an active date till spring 2020. Freedome still worked, even after getting the expired subscription. Got a similar expiration message on my iPad as well. 


Rebooted my Mac laptop today and now the Freedome program will not load. I get an error message: "Oops. Could not connect to the server. Check your Internet connection and try again." In between clicking on the "Try Again" button I can get to the subscription page and enter my code, usually it hangs, but once said it was unable to verify my subscription. Nonetheless, the dang "Oops" error comes back over, and over and over, until I finally say quit.


Things I tried to fix:


1) Rebooting the laptop again, did nothing to fix.

2) disable anti-virus, did not fix

3) uninstalled anti-virus, rebooted - did not fix

4) uninstalled Freedome, rebooted, reinstalled - did not fix


Any ideas as to what went wrong and what I can do to get it working again? Very frustrating as I went through this on my Mac desktop a month or two ago and just gave up on using the VPN on that machine. 


MacBook Air, Mac OS 10.14.5 - Freedome, the latest version downloadable from your website, Subscription active till March 2020 according to the confirmation email when I resubscribed. 



  • Jaims
    Jaims Posts: 846 Former F-Secure Employee

    Hi @Rickl 


    Did you perform a clean installation by removing the old installer files and F-Secure folders from application and trash before reinstalling? If yes, then you may try the below steps and see if it works;


    - Click the Apple icon then select the System Preferences… option
    - Select Network
    - From the left pane, select the network service you wish to disable the proxy settings on, then click the Advanced... button
    - Select the Proxies tab then uncheck all protocols under Select a protocol to configure then click OK once done


    Try to run Freedome again and let us know if these steps work.

  • Rickl
    Rickl Posts: 3 New Member

    Hi Jaims,


    Problem turns out to be with my isp blocking vpn's. When I went off-site and tried at another location, it loaded perfectly fine. Luckily only have the current isp at home for another month. When loaded ahead of time, it tends to work okay.


    - Rick

This discussion has been closed.
Product & Pricing Info