Firefox: "Browsing Protection by F-Secure could not be verified for use in Firefox

"Browsing Protection by F-Secure could not be verified for use in Firefox and has been disabled". This notice appeared on May 4, 2019

Comments

This discussion has been closed.