Firewall Blocking Unity

I downloaded Unity game engine from the internet and installed it on my laptop but the only way I can get it to connect online is by unloading the firewall ( I use f-secure from charter internet) once I get the program up and running I can turn the firewall back on and everything works fine.

 The strange thing is that in the program settings part of the program it shows that Unity is allowed to access the internet but like I said  it won't connet till I unload the program.

Do you have any Idea what may be causing this and what I might could do to solve the problem.

Thanks for your help.

Ken

Best Answer

Comments

  • JaniashviliJaniashvili Posts: 469
    are you sure it's Firewall the problem?

    (turn off/disable firewall from settings and check again if unity works).

    otherwise, open those ports manually
  • ken28637ken28637 Posts: 3

    Yes I'm sure the firewall is blocking Unity, I unload Charter Security Suite ( F-Secure) and  the program will connect just fine, now as for opening a port I can try that if you think it will help, in the settings part or F-secure it shows  ( c:\program files\unity\editor\unity.exe) automatic/allowed but till I unload F-secure it can't access the Internet. I will go to the open port part aand see what I can do there and let you know.

    Ken

  • steve_jsteve_j Posts: 5

    I disabled the avance process monitoring and it works fine for me.I too had the same problem ealier

  • ken28637ken28637 Posts: 3

    Ok I got it to work I went into the settings part of F-secure, application control and added it there allowint it to connect to the internet, I set both outbound and inbound to allow and it seems to be working fine.

    Thanks everyone for all your help.

    Ken

This discussion has been closed.