Freedome won't start. MAC OS

This is starting to happen to me on a regular basis and it's really getting tedious. Freedome just won't start. I've tried quitting and restarting, deleting the F-Secure folder from my Application Support Folder, deleting everything and reinstalling, rebooting the computer, and it just spins indefinitely when I try to get it started. I'd like to get it going again, but I also want to make this weekly problem STOP. Help, please. There are other VPNs on the market, you know.

 

MacOS Mojave

10.14.3

Comments

  • SethuSethu Posts: 638 Moderator

    Hello @lghtstrm1 

     

    Just to make sure that you have performed completely remove F-secure Freedome. Please refer this KB article to see complete removal  of Freedome, and try re-install  to check again. 

     

    If you issue remain, please provide us some information about the Freedome not working issue. 

     

    Is there any third party VPN running along with Freedome VPN?

     

    Are you using any anti-virus software for your Mac? if yes, you may try disable the anti-virus for sometime to check whether the issue reproduce. 

     

    Have you tried disable all Freedome features i.e Kill switch, Browsing protection,. to find the poblematic components?

This discussion has been closed.