Freedome disrupts internet service when turned on.

Hi, my Freedome works great on my wireless devices, but with my desktops I cannot get any service at all until I turn Freedome off. I live in the US and have Optimum Online as my ISP. Its clear that the issue is not poor services from my ISP, its just that I'm quickly lose my connection to the internet on any desktop computer when Freedome is on. Its easy to fix, just go to Freedome and turn it off, and my service immediately resumes. But that's now why I'm subscribing to this VFN service. Any ideas on how I can can beat this?

Comments

  • DumelaDumela Posts: 6
    BTW, I'm using version 2.25.5766.0 with Windows 10 64-bit.
  • JaimsJaims Posts: 397 Moderator

    Hi @Dumela 

     

    May I know if you tried to uninstall and reinstall F-Secure Freedome VPN to restore the default settings and see if the you are able to connect to the internet afterwards?

     

    Click here to see the functionality of Killswitch perhaps that could be the possible cause.

     

    Let us know if this solves the issue.

  • DumelaDumela Posts: 6

    Hi Jaims.  I reinstalled as requested and ensured that the kill switch was disabled.  Still no change (i.e. when I turn on Freedome, it works for about 30 sec / 1 minute before everything stops.  And when I turn Freedome off, it goes back to work immediately).

     

  • JaimsJaims Posts: 397 Moderator

    Hi @Dumela 

     

    In that case, may I suggest that you kindly contact our technical support so they could troubleshoot this issue for you.

This discussion has been closed.