Computer Security Off?




      I have recently installed F-Secure 2012 and recently the Windows Security Centre has been showing that the Computer Security is off. (i.e. no firewall and virus/malware/spyware protection).

When go to the F-Secure Launch Pad and click the Computer Security tab, a graphic appears which says 'turning on' but nothing seems to happen and nothing changes.

I am concerned that I am not protected.

Any ideas. Thanks. 


  • Janiashvili
    Janiashvili Posts: 454 Adventurer

    maybe it's still downloading updates and that's problem.


    wait some time and then restart computer and look if problem is solved

  • Meester-Chris
    Meester-Chris Posts: 8 Explorer



    I already did that - F-secure did not re-engage.

  • Skuggan
    Skuggan Posts: 25


    Same problem here on all computers, wth is going on?

    When I bought this program I expected to be protected always, not sometimes, and making me spend time by re-installing the **bleep** thing is not something I prefer to do on my spare time.

  • Patlar
    Patlar Posts: 4 New Member


    This morning on booting up my PC. My F-Secure prompted me with the message - 'your computer is not protected'. On activating F-secure i saw the large red button with the white X in top lefthand corner and in red - 'your computer is not protected -' I am a fully paid up subscriber and I downloaded the 2013 version of F-Secure in late May or early June 2013. this is the first problem I have had with 2013 version. What  can I do?



  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi Patlar


    With regards to your problem, I would suggest you to open a Support Ticket:

    Once you have open a SRID kindly update me so that I can help to solve your issue.


    Best Regards,

  • sav
    sav Posts: 3


    restored my sons pc, so i needed to re install security on his laptop, no problem, this morning i found no protection on my pc, subscription expired it says, not true.

    any help out there.


  • Ukko
    Ukko Posts: 3,640 Superuser



    You can try re-install F-Secure again - if I correctly understand... you are already re-install system or "restore back up point".


    Anyway - it's possible.. that subscription just "stuck" in previously installation.


    Probably... you can or need two points to do:


     - re-install F-Secure with utility F-Secure Uninstall Tool (it's mean - first - by default function in system; next - use that utility, for example - and already after that - install it again).


     - create a ticket to F-Secure Support about situation - which probably can to help with "re-check/-re-change" subscription-points.


    Sorry - if I not correctly understand your current trouble.

  • NikK
    NikK Posts: 903 Forum Champion

    @sav  When you have a subscription with more than one license, this can happen when you restore a computer without first un-installing the F-Secure product. But If you re-install on your PC you probably will be notified that all licenses are in use and you'll be asked to move a license. When you do that the product will release the old license from before you restored your sons PC, so you can re-use it.


    You can view the status for all licenses for a subscription by right-clicking the F-Secure icon in the systray and select "View my subscriptions".


    PS. If you have purchased SAFE then you control the licenses from the SAFE Portal, and you need to remove the "old" installation for your sons PC in order to free that license.

    Give Kudos to say "thanks". Click "Accept as Solution" to inform others when your issue's been solved

    Need more help? Submit a Support Request or chat with or call F-Secure support. Or try the User Guides

  • sav
    sav Posts: 3

    sorted it. mant thanks for your help.


  • sav
    sav Posts: 3

    thank you, i think you where correct. many thanks for your time.



This discussion has been closed.
Pricing & Product Info