F-Secure DeepGuard/Ultralight Hoster impacting Robloxplayerbeta.exe



When starting the robloxplayerbeta.exe application the error "Initialization error 4" is produced. Upon disabling DeepGuard, this then allows the application to run; additionally, disabling the service "F-Secure Ultralight Hoster" allows the application to run, as well, therefore, disabling either of these configurations allows Robloxplayerbeta.exe to run. 


1. What about DeepGuard is impacting this app?

2. What is Ultralight Hoster, and why is this impacting the app, too?




  • Joe_McLeod
    Joe_McLeod Posts: 1 New Member

    This is deeply impacting me and my son's ability to use F-Secure/Deepguard with Roblox Player.... I dislike the idea of turning off Deepguard to play in Roblox.


    A compromise that we are attempting is to switch Deepguard off long enough to allow the player to start, and then re-enabling Deepguard after the Roblox ame client is running.


    I am not sure what if any risks I am incurring by doing this; any advice on this?


    It looks like the developers aren't in any particular hurry to look into this (there are a small handfull of related posts to the Roblox Player Initialization Error -4 issue with DeepGuard that are all single answer issues), as Roblox is largely a game environment played by younger kids in my son's age range (pre-teens) and therefore isn't a major software breaking issue.


    I also noticed that this issue cropped up right after I installed Visual Studio 2017 Community with various development add-ins for Unity and Xamarin.

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi @Joe_McLeod  and @crashfive ,


    I checked with our labs and they mentioned that the issue with Roblox has been fixed. Please restart your computer and let us know if you still notice this issue.

  • Per_M
    Per_M Posts: 1 New Member



    I read your last post, and as I have the same problem I was pleased to see that the issue had been resolved. However, the problem remains. The same error message appears Initialization error 4. As I have had the problem for a while and my son is getting rather frustrated I started to search the web for solutions. Through my search I can see that it has been an issue for some time and the official suggested solution has always been the same "clear local ORSP" by rebooting as the issue has been solved. However this does not work.


    Any new suggestions or information when this will be resolved. Messing with Deepguard is not an alternative.



    Per M

  • crashfive
    crashfive Posts: 3 New Member

    It might behoove you to use an alternative malware protection software. It’s unfortunate that F-Secure labs opts to allegedly share the problem as resolved when in fact it is not. May I suggest Malwarebytes, I’ve seen quality protection without any Roblox impact. Good luck!

  • anttijm
    anttijm Posts: 1 New Member

    We are having the problem too. Disabling Deepguard fixes the issue so I think it's still the same bug... 

  • crashfive
    crashfive Posts: 3 New Member

    False. Your labs are wrong. We (the community) are still seeking a solution. Thanks.

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hello Everyone,


    Since the issue persists, could you please submit a copy of the file Robloxplayerbeta.exe to our labs here for analysis?

This discussion has been closed.
Pricing & Product Info