Freedome won't connect to a server

https://gyazo.com/508e986e38671600bdca3513232fedb3
Freedome worked fine about 2 days ago suddenly it start acting up and won't connect to anything. 

Comments

  • Same here!

  • It's also worth noting that i've tried every solution in the forum such as uinstalling resetting dns and everything else so please come with a response other than the above :) 

  • I found another post on the forum about OpenDNS blocking it. I recently switched to OpenDNS, and I think they recently started blocking. I'll have to test later. 

  • Yea thing is i don't use opendns so that wouldn't be an issue for me 

     

  • SethuSethu Posts: 644 Moderator

    Hello @ChrisNielsen 

     

    May I know in which country do you live in now?  are you using any security software along with Freedome VPN?

     

    Do you have Freedome installed on your mobile? If yes, have you tried to connect your device with different network? i.e wifi to 4G

  • grablagrabla Posts: 4

    If you try to connect to freedome-vpn.net without switching freedome on,  does it connect?

     

     

  • I live in Denmark i use windows deffender and i use it on PC

  • SethuSethu Posts: 644 Moderator

    Hello @ChrisNielsen 

     

    Since you have performed all the basic troubleshoot steps for the issue. Please contact our F-secure support for further investigation.

This discussion has been closed.