Freedome connection

Hi There

 

so I can see a few people are having issues with freedome connection. I too am having similar issues. Freedome wont connect but if I switch it off I can access the net. I am currently abroad but have my location set as UK.

 

I have the most uptodate version as of 1st March

 

I have cleared my browser history and cache.

 

I have tried multiple restarts

 

Anythings else I need to do? It seems like this is not an isolated issue. it was working fine 2 days ago

 

I am on a Mac running OS 10.14.1 and have not done any updates etc recently

 

Please help 

Comments

  • SethuSethu Posts: 644 Moderator

    Hello @rc951 

     

    Thank you for reporting us the issue, please provide us some more information about F-secure Freedome not conneting issue. 

     

    May I know in which country do you live now? have you tried to connect your device with differnet network? i.e Wifi to 4g/3g

     

    Are you getting any error message during connecting Freedome?

This discussion has been closed.