Unable to start F-secure freedom

I have had the F-secure Freedom installed on my Mac Mini for several years. Today it refused to start. I uninstalled it using the Mackeeper.app and installed it again. The installation ended with "Could not configure the app. Restart Freedom and try again." I restarted, to no avail. I uninstalled the app, shut down the computer, started it anew and installed the Freedom, with the same result.

Comments

  • SethuSethu Posts: 642 Moderator

    Hello @Lassijuhani

     

    May I know the version of your Mac OS? 

     

    Also, may I ask you to try remove Freedome completely by following the steps from this article? and using uninstallation tool

     

    Will you then please try check re-instalallation?

  • Mac OS Mojave 10.14.3. The problem started actually after my Mac Mini had been updated to this OS version. I uninstalled the Freedeom using the MacKeeper smart uninstaller, shut down the computer and started it again. I tried to reinstall the Freedom with the same result.

  • SethuSethu Posts: 642 Moderator

    Hello @Lassijuhani,

     

     

    In such case, we need to analysis the logfile in order to find the error message that related to installation issue. So please contact our F-secure support team for further investigation is required.

This discussion has been closed.