Unable to connect to my NFS shares when Freedome in ON

aizzi Posts: 1 New Member

I use NFS on my Win10 to connect to a couple of NFS shares on my FreeNas server. I have no problems in connecting when Freedome is OFF, but as soon as I turn it on I loose the connection. I get it back immediately when I turn Freedome off again. I'm using IP addresses to connect, not hostnames.


Traceroute with Freedome OFF:

Tracing route to FS01 []
over a maximum of 30 hops:

1 3 ms 2 ms 1 ms FS01 []


Traceroute with Freedome ON:

Tracing route to FS01 []
over a maximum of 30 hops:

1 gateway.freedome-vpn.net [] reports: Destination host unreachable.


It appears that Freedome is trying to protect me from my very own intranet.


  • XVX
    XVX Posts: 12 New Member

    Same here! NAS is not working anymore (Local network, SMB), cannot access to the NAS Dashboard either from the web interface. Cannot connect to the server when Freedome is ON. Have to turn Freedome OFF!


    I lost an hour from my day looking to fix this issue (thought it was in my Mac), until i checked Freedome and turned it off. So, windows isnt only affected, also MacOS which means that Freedome is the culprit. 


    Connection with shares are lost immediately Freedome is turned on. 


    What is going on!?

  • XVX
    XVX Posts: 12 New Member

    Have you tried to turn of the "kill switch"? (freedome -> settings -> kill switch) it help for me and now im able to connect shares again. 


    Please Fsecure - Fix it, kill switch is needed!

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hello XVX and aizzi,


    We would like to get further information in order to troubleshoot this further.


    Could you provide more information about your network; such as IP address and netmasks for your PC, router and the FreeNas you are using? You could send me a private message with these information rather than posting it in here.

This discussion has been closed.
Product & Pricing Info