TP LINK and FREEDOME : not connecting

Hi,

 

I recently started using a routeur (TPLINK AC1750) to connect to the internet (to expend my wifi range). I'm still connecting with my computer to the routeur trough ethernet cable. Since then, I can't connect to F-Secure FREEDOME. When I click on "Protection OFF" (to set it ON) it stays on "connecting" for ages and nothing happens.

It worked fine before that.

 

Any idea how to fix that problem ?

 

Thanks for your time !

 

Jylu.

Comments

  • LakshLaksh Posts: 4,430 Community Manager

    Hi Jylu,

     

    Please have a look at this article for port configuration for Freedome on Mac/Windows. Please try this and let us know if it helps.

     

  • JyluJylu Posts: 3

    Forwarded the ports, still not working... Anything else I could do ?

  • LakshLaksh Posts: 4,430 Community Manager

    Hello Jylu,

     

    May I know the version of Freedome installed on your device? Also, the OS version of your device? Does it happens on all your devices or only on certain devices?

     

    Does it help to change the location with Freedome and connect?

     

  • JyluJylu Posts: 3

    Freedome version : 2.23.5653.0 

    The divice OS is Windows 7. I'm using freedome only on this device. 

     

    The weird thing is that it does not work only when connected through ethernet cable to my routeur (e.i. it works when I'm connected through WIFi).

    The thing is, I need to be connected through cablesbecause otherwise my connection is bad.

     

    Changing the location does not help.

     

    Thanks.

This discussion has been closed.