Freedome iOS dropping out shortly after device wakes

I've got the "keep VPN on when device is idle" enabled, but I've found that after waking my iOS device the Freedome VPN will work briefly and then dropout for a few seconds before reconnecting.  This happens usually within the first 20-30 seconds after wakeup. 

 

If I'm browsing this is just annoying, but if I'm on a (data) call it means it will dropout and I'll need to call again.  This seems to have increased in frequency in the last few months.

 

I've tried removing the profile and re-installing - to no avail.  Any tips?

Comments

  • LakshLaksh Posts: 4,432 Community Manager

    Hello Vwo,

     

    Could you please try to unselect “Keep VPN on when device is idle” setting and check if the behaviour remains the same?

  • hey for me why it was working smooth on my iPad Pro when it was running on ios 10 however as I have updated to ios 11.3 whenever now I am opening the app it only loads a blank screen on the start up and crashes after a while automatically. How do I fix it?

  • VwoVwo Posts: 2
    This seems to work; but unfortunately makes it very hard to answer VoIP calls (the reason I originally turned that setting on). If the VPN isn’t already active when a call comes in I need to wait for it to reconnect before I can answer the call. This usually results in the call timing out or dropping.

    I’m also concerned about the traffic from idle activity not being protected by Freedome.
  • LakshLaksh Posts: 4,432 Community Manager

    Hello Vwo,

     

    The traffic from the iPhone will be protected in this scenario too – the VPN connection is opened each time any app from the device tries to access the network. The “Keep VPN on when device is idle” setting was included when Whatsapp (and possibly a couple of other similar apps) didn’t get the messages with a couple of different earlier versions of the iOS operating system.

     

    I would recommend to get in touch with the support team here along with the logs so that they can investigate this further.

This discussion has been closed.