Cannot uninstall nor re-install SAFE on Mac Mojave


The uninstall icon appears in the dock after double-clicking in Finder. But after clicking on the uninstall icon in the dock, nothing happens.


Trying to re-install SAFE over the existing installation, the install is getting stuck mid install, and I cannot restart the Mac because I get a warning that the install needs to complete.


Any advice please?


  • Simon
    Simon Posts: 2,667 Superuser

    There's an Uninstallation Tool for Mac which might be worth a try.  Second one down here:


  • Carl2
    Carl2 Posts: 9 New Member

    Thanks for the link. After loading the uninstall app in the dock, it did not work, and the Activity Monitor showed nothing happening.


    The MacBook was very sluggish, so I restarted the Mac holding down Command and R, and then re-installed a clean version of Mojave. For now I'm leaving SAFE uninstalled.

  • psaijai
    psaijai Posts: 4 New Member

    I have same problem with Mojave and F-secure SAFE. Real time protection is making Mac working really slow and F-Secure database update is stuck. It only stay "in progress".


    Uninstall tool not working with Mojave. It only keep jumping in dock and nothing happens.


    I did disable real time protection from settings and now computer is working well, just not protected by F-secure. Please fix your software and please start testing with Beta versions. Safari12 extension still not ready?

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hello Everyone,


    SAFE for Mac 17.4 has been released, and we have started the automatic updates. Could you please try to install the SAFE for Mac 17.4 version and check if it helps with the issue?


    If don't want to wait for the automatic update but want to install the latest version immediately, log in to your My F-Secure and install it manually. 

  • oldbok
    oldbok Posts: 1 New Member

    I had difficulty after doing a Mojave upgrade on a 2012 Mac Mini. 

    My system ran slowly and erraticly and eventually became almost unusable.

    What worked for me was this:

    Re-istall Mojave from the command-R start-up procedure

    Completley remove F-Secure Safe with the  uninstall tool

    Re-download and re-install F-Secure Safe

    Everything is OK now.


This discussion has been closed.
Pricing & Product Info