No internet connection with home wlan when Freedome is on

I have to switch off Freedome when using Home WLAN that I can be connected to internet.

Also when starting there comes several information that Freedome is protecting as if it would be connected several times

ZarZentZorg

Comments

  • The issue has been discussed on this forum for a long time but no solution provided by F-Secure. It happens with my devices using Windows 10 and also occasionally with iPhone IOS. The simple solution is to temporarily manually turn OFF Freedome, switch on internet browser, and then turn ON Freedome. 

     

    A geekier approach is to go to Task Manager, open the Services tab, right-click Freedome Service and choose Open Services, right click  F-Secure Freedome Service and choose Properties, switch Startup type to Automatic (Delayed Start) and click OK, and exit Services and Task Manager. Restart your device and you should see that you can have access to internet immediately after thesystem launch which means that you got rid of that error message also from Freedome which informed you that can't connect to internet.

This discussion has been closed.