Freedome for MacOS is slow to connect

TeroHTeroH Posts: 17 Observer



Establishing the VPN on my Mac can be really slow at times, it may take a minute or 5 minutes, and sometimes, like today, it never completes. At times it takes less than a second, which I expect to be the correct behavior. When Freedome refuses to establish the connection at all, the network is completely unresponsive despite turning Freedome off, and a system reboot is the only way out. This is a new behavior that did not exist prior to purchase of Freedome.


As a bonus, Freedome for Android refuses to connect on Brave browser when swithing from WLAN to mobile network. Turning airplane mode on and then off helps every time.


I've had these issues for the whole time I've been using Freedome, and the problem refuses to go away despite my contacts to the support. The suggested resolutions are not effective.


Are these issues regarded as normal behavior or are both Freedome software (or my devices) defected? I don't like the way Freedome prevents using my devices, requiring daily workarounds.


My MacOS is the latest version and the device is an iMac with enough hardware resources.


Accepted Answer


  • LakshLaksh Posts: 4,444 Community Manager

    Hi TeroH,


    May I have the below information regarding your issue?

    1. What is the version of Freedome installed on your Mac currently?

    2. Have you tried to connect to a different network than your usual WiFi/data network and see if the situation is different? Does it connect faster in other networks?

    3. Does the slowness to connect happen only with a particular location or does it happen with all the locations?

    4. On your Android, could you please explain more on what is the issue? Please elaborate more on 'Freedome refuses to connect on Brave Browser'.


    Since you have mentioned you have already contacted support, have you provided the logs from Freedome to the support team to troubleshoot more on this issue?


  • TeroHTeroH Posts: 17 Observer



    thanks for the response.


    1. The Freedome for Mac is 2.22.5577.0

    2. I haven't, but I can test that today.

    3. This is an iMac, so physical location and the network does not change. 

    4. In Android, the data communication dies completely when switching from WLAN to mobile network, and it does not start working without manual workarounds. The Freedome does not establish a VPN connection, so DNS queries don't work and web browser loads nothing.


    There is, however, onother common nominator for both cases, the same WLAN AP.


    There's been no log data involved in the support cases so far.

  • LakshLaksh Posts: 4,444 Community Manager

    Hello TeroH,


    Sorry for the confusion. The location I meant is the virtual location you are using in Freedome. Please try to connect to a different virtual location (different country) in Freedome and check the connectivity.


    Regarding your Android, could you try to turn off the Killswitch feature in Freedome and check if the issue persists. You can read more about the Killswitch feature here.




  • TeroHTeroH Posts: 17 Observer

    I have 2 answers now. Freedome for Android received an update today, and after installing it I can't reproduce the problem anymore.


    In Mac, setting virtual location to something else than what I've been using does not make Freedome any quicker to establish the VPN connection. It still takes minutes rather than seconds. I briefly tested it over the mobile link also with no definite answer so far. At least in the 5 occassions I've tried so far it has established the VPN within 10 seconds.


    How long should establishing a VPN connection take at most on a modern computer and 100M cable connection with a very short RTT and nothing wrong in the client side?

  • LakshLaksh Posts: 4,444 Community Manager

    Hi TeroH,


    Thank you for keeping us posted about the resolution. Good to know the issue has been resolved.

This discussion has been closed.