Turn off automatic "Check for updates"

Hi all,

In dire need of help. I need to stop the frustrating automatic update system in F-Secure Safe. It's driving me crazy.

I have recently reinstalled to sort the issue of major hardware use, but it still hogs the CPU and RAM whilst it is updated and makes my laptop go insane.

 

Is there a way to reduce the amoutn of times it updates? I really hope there is because it's driving me crazy. I have  looked the method suggested through the F-Secure buisness reconfiguration but I think the two software packages are different. I'm not literate in code so I don't know how, but any easily fixable suggestions woudl be greatly appriciated.

 

Cheers,

Comments

  • SimonSimon Posts: 2,610 Superuser

    Automatic updates are a critical function, and as such, I doubt that you can disable them (but I expect someone will prove me wrong, as usual).

     

    Are all of your current updates installed?  If you right click the tray icon and go to Common Settings, you should see all of the components and this should also confirm that all of the updates have been installed.  Sometimes, if an update gets 'stuck', this can affect other component updates, so that's worth checking. 

     

    Similarly, do you have all of your Windows Updates installed?  On my Windows 10 laptop, I seem to be in a constant battle when trying to get anything done, with Windows 10 updates hogging bandwidth and CPU/RAM.  Could it be this that's causing your problem, rather than F-Secure?  FS updates, for me anyway, are usually pain free.  The only time there's a bit of an impact on resources is when there's a major product update, but this is different to the usual signature updates, which are usually relatively small.

    Ukko
This discussion has been closed.