Slow internet speed when Freedome on

I just renew my Freedome for another year and noticed that the internet speed is useless.

Without Freedome speedtest (DNA my internet provider/Ookla/others) my internet speed is 195/20Mbps with all devices.

When i turn Freedome on I only get 40/16Mbps.

 

This same thing happens with 

1. Windows 10 PC ,AC wlan: 40/16Mbps

2. Xiaomi mi5 Android phone,AC wlan ,40/16Mbps

3.Android TV box, AC wlan, 80/16Mbps

 

-All Freedome apps are up to date 

-I have tried all locations. Finland is the best

-F-3686AC cable modem IPSec PassThrough setting enabled.

 

What to do next. 200mbdown to 40-80Mb is way too slow. Is this normal or is there still I can do?

Thanks.

-Tuomas

 

Comments

  • PavitraPavitra Posts: 81

    Hi OOP,

     

    welcome to F-Secure Community!

     

    May I know what is the version of Freedome is installed on your device?

     

    Have you tried to connect to a different network and check if the issue persists (may be a different Wi-Fi or Data Network) ?

     

    Thank you

  • OOPOOP Posts: 2

    2.22.5580.0 is the version. It should be the latest.

     

    I don't have other internet connections to test with.

     

    -Tried also port forwarding (For android tv box i think this might be the reason it will get 80mb

    • TCP/UDP ports in the range 2740 - 2749
    • TCP port 443

    -Tried DNS flush: IPCONFIG /FLUSHDNS in cmd

    -Tried reinstall network devices: netcfg -d in cmd

    -Uninstalled /reinstalled Freedome

    -Tried LAN, got only 80mb through without freedome and 40mb with freedome. probably 100M card in my laptop

    No luck with any of those..

    what next?

  • Hi there...

    I have the exact same problem, hope to hear about a solution.
    Or should I claim my money back
This discussion has been closed.