IPv6 Connectivity on macOS

While testing Freedome 2.20.5548.0 on macOS 10.13.6, I noticed that, while Google Chrome accesses the IPv6 Internet, Safari does not.

Using a reliable site such as test-ipv6.com to diagnose the issue results in the Safari test returning "IPv6 connections work, but connections using DNS names do not use IPv6. For some reason, your browser or your OS is not doing IPv6 DNS ‘AAAA’ lookups.”

It somehow looks as if the tunnel created by Freedome did not register the IPv6 DNS capabilities, so that Chrome, which partly uses its own networking stack (for better or for worse) detects and uses it, but Apple’s own apps do not.

Any thoughts? I remember IPv6 was long declared unsupported by Freedome, but things seem to be changing…

Comments

  • Step 1

    Log in to the router’s web-based management page, and please click here if you don’t know how to log in.

    Step 2

    Go to IPv6 Support at the left hand side men. In the drop-down menu of IPv6 Support, please choose IPv6 Setup.

    Step 3

    Please make sure that Enable IPv6 has been checked. Select DHCPV6 as WAN Connection Type.

    Select “Get IPV6 prefix delegation”.

    For the IPV6 Address Assign Type, please choose SLAAC.

    Then click at Save.

    If you tried the above steps, and still no IPv6 internet, also contacted with TP-Link Support but nothing happened.

  • LakshLaksh Posts: 4,432 Community Manager

    Hello Tarsier,

     

    Please get in touch with our support team here via chat or phone so this can be investigated further.

     

This discussion has been closed.