Useless VPN - 03.07.2018

Have been using Freedome for a month or so. Not had any issues connecting from Indonesia to the Espoo location.


Today none of the virtual locations worked and videos were left in buffering loop.

Speedtest also gave less than 1mb/s which isn’t even sufficient for email.

When I used a free vpn , Touch VPN I had no issues, except I cannot get a Finnish ip with it.


Was there some sort of issue with Freedome today? Hopefully I won’t experience the same tomorrow.


Best Answer

  • Cronus71Cronus71 Posts: 3
    Accepted Answer

    Problem seems to have solved itself. I’ve had no problems since yesterday 05.07.2018.



  • LakshLaksh Posts: 4,432 Community Manager

    Hello Cronus71,


    May I know what is the version of Freedome installed on your device and the OS of your device?


    Do you still happen to see the issue?



  • Cronus71Cronus71 Posts: 3

    Hi Laksh,


    Thank you for the reply.


    The situation is a little better. Though I get buffering every 2 minutes or so.

    my Freedome version is, and it’s in an Android 6.0.1 system.

  • LakshLaksh Posts: 4,432 Community Manager

    Appreciate the update, Cronus71.

  • Frank77Frank77 Posts: 2

    I have the same issue.even after i downloaded and reinstalled

  • LakshLaksh Posts: 4,432 Community Manager

    Hi @Frank77,


    May I know if you are seeing the slowness in all the locations? What is the version of Freedome installed and the OS of your device?

  • Frank77Frank77 Posts: 2

    Hi Laksh! I have win 7. And now i also have the latest update. Freedom is still  just looping in trying to connect to what ever area i chose. While doing so blocking me to internet. I have tryed my old vpn program and it works fine. Tryed your free diagnostics and no problem to find. Are beeing in sweden. What is the problem???

This discussion has been closed.