Protection switches off

Hi

 

Using F-secure on an android powered Galaxy Tab S. The subscription lapsed for over a year, but it used to work. Now when I switch on the protection, it switches itself off after 30 seconds.

 

Has anyone any suggestions?

 

BigT

Comments

  • Laksh
    Laksh Posts: 4,444 Former F-Secure Employee

    Hi BigT99,

     

    Since you mentioned the subscription lapsed for over a year, is the subscription still valid?

     

    Does it happen with all the locations on your device?

     

    What is the version of Freedome installed and the OS version of your android device?

     

  • BigT99
    BigT99 Posts: 4

    Thanks Laksh.

     

    I bought a new license before downloading the app.

     

    i've only tried England & Spain, but it doesn't work on either of those

     

    It's version 2.5.1.7586

     

    On a galaxy tabS,  OS using android 6.0.1.

     

    Annoyingly it works on my Galaxy S9

     

    Regards

     

    Tony

  • Laksh
    Laksh Posts: 4,444 Former F-Secure Employee

    Hi Tony,

     

    Have you tried to uninstall and reinstall Freedome on your Galaxy Tab S? Please reinstall Freedome and check if it helps.

  • BigT99
    BigT99 Posts: 4

    Sorry, missed your reply so this is late

     

    I have tried reinstalling Freedome, to no avail.

     

    Tony

  • Laksh
    Laksh Posts: 4,444 Former F-Secure Employee

    Hi Tony,

     

    Have you tried to connect to a different network and see if it helps; for example, connecting to a data network if it does not work on a Wi-Fi network?

     

    Please check this article about VPN disconnecting frequently on Samsung devices.

     

  • BigT99
    BigT99 Posts: 4

    Thanks Laksh

     

    I haven't tried that yet, but will do when I'm at home. The urgency is over - I can connect from Spain through my phone (Galaxy S9) to watch the football and cycling, so I'll leave it for now.

     

    Thanks for help

     

    Tony

This discussion has been closed.
Product & Pricing Info