XFence: system update to 10.13.5 on MacOS fails over and over again

R8R8 Posts: 10 New Member

I'm trying to update my Mac with the latest Command Line Tools for Xcode, plus the update to High Sierra 10.13.5. When doing this, I disable Xfence, because otherwise it won't work in my experience. These system updates then all proceed, and at the latest moment it fails. So I disable Xfence, and then it works out, and after a restart Xfence is activated automatically.

 

Several weeks ago, the update for Command Line Tools could not be installed. I tried this several times. Now I see a new update with a system update to 10.13.5 as well. When I disable Xfence, then start the update, I get an alert that another 6.64 GB is needed on the system disk. I had 5GB free at first, now have freed up to 28GB. Still I get this alert.

 

How do I get this update working?

Best Answer

  • R8R8 Posts: 10 New Member
    Accepted Answer

    So in the end I had to do the restart myself, and after that, Xfence was updated. Not the way it's supposed to be, but at least it works now.

Comments

  • R8R8 Posts: 10 New Member

    Replying to myself: My macbook runs without restart for weeks, sometimes months. If I don't have to restart because of updates, I won't. But this problem made me do a restart, disable Xfence, and then the update for the command line tools worked. It needed a restart, and after that I could update to 10.13.5. All is good.

     

    Except...

     

    Now I get an Xfence update from 1.6.6 to 1.8.88, and after disabling Xfence I run the updater, and after a while the update popup disappears and nothing happens... I can do this over and over again. Doesn't seem like how it should be.

This discussion has been closed.