Samsung Andoid Phone completely disabled

When I tried to open my phone yesterday (Friday), I got a message saying "phone disabled. Contact IT Administrator". I took it in to the Samsung Service centre in Milton Keynes where they said the issue was due to F-Secure as this was the only type of app that could completely shut my device down. I have tried removing the licence from the phone (Samsung S7 Edge) but this has not worked. There is no online support over the weekend and F-Secure's opening hours are Mon-Fri so it looks like I will be without my phone all weekend. The service centre have told me that, for £25.00, they can completely wipe my phone but I will of course lose everything that it stored on it. Thanks F-Secure!


  • Simon
    Simon Posts: 2,667 Superuser

    Can you get into your phone at all?  I believe there's a method to enter a Safe Mode, which you might be able to Google.  


    I'm not convinced this is down to F-Secure (unless somehow the phone security had been compromised).  I don't know if it will help, but I did find this:


  • Spud1954
    Spud1954 Posts: 4 New Member

    Thanks Simon. I have read your link page but it is a slightly different issue from the one I am experiencing as I am unable to get access to my phone at all so can't access the setting menue etc. I did try the Google approach but, in order to sign in to my Google account,  it texts me asking me if I am trying to sign in (Yes/No) and then texts me a number to enter. As I can't gain access to my phone I can't sign in using this method. 

  • Simon
    Simon Posts: 2,667 Superuser

    I didn't mean for you to sign in to your Google account - I just meant for you to search on Google for how to use Safe Mode.  You might find this helpful, assuming you can at least access the power on/off functions of the phone:



    If you can get into Safe Mode, you may be able to disable or remove F-Secure, which will then confirm whether it has caused the problem.



  • Spud1954
    Spud1954 Posts: 4 New Member

    Thanks Simon. My friend, who is a bit of an IT wizard, tried doing this yesterday and now I get the additional message: "This phone is lost. Please give it back. Call the Owner" Unfortunately he has set it to call his  own number. Underneath it says "Locked by Find My Device". Strangely, my son called me yesterday and I was still able to answer the call. That is about all I can do at the moment.

  • Simon
    Simon Posts: 2,667 Superuser

    OK, well perhaps after all it seems something may have triggered the F-Secure security.  I don't use the app myself, so I don't know if there's any way around that.


    Could you possibly log into your Google account from another device, and see if there's anything there that can reset it?


    Otherwise, I guess it's back to where you started from, and it will be a case of contacting Support on Monday.

  • Ukko
    Ukko Posts: 3,611 Superuser



    Sorry for my reply. I'm also only F-Secure user (their home solutions).


    Even I did not try to "lock" Android device by F-Secure solution... but I think that it should not be autolocked/blocked or something like this. Only by manual direct commands from "My F-Secure Account" portal.


    Based on some articles from web -> sounds that maybe your experience is about something like 'applying' Policies to your phone. For example, I read about potential situation when user connect/use Google Mail account to his 'business' account (or something like this; or from business phone) and result is 'restrictions/policies'. With such situation - it is likely that phone is locked on weekends (for example) or if certain triggers are reason for 'lock'-command. So, it will be good to read your feedback after all!



  • nanonyme
    nanonyme Posts: 145 Path Finder


    Locking your device remotely is something built into Android phones accessible through linked Google account. If your phone got locked and you're sure you haven't been accessing find my device functionality, it's also possible you're Google account has gotten compromised and you should change password and make sure to enable two-factor authentication. Any application running on your phone with admin privileges can as far as I know lock up it so you also need to be really careful what you give admin permissions to.

  • Ogi
    Ogi Posts: 1 New Member
    did you manage to unlock? I have same problem on unlock screen pin, I tried severally and it says now device dissabled. contact IT adminiatrator How do I get around it?
  • joanne3422
    joanne3422 Posts: 13 Explorer

    Could you possibly log into your Google account from another device, and see if there's anything there that can reset it?Otherwise, I guess it's back to where you started from.

  • Bluemustnag22
    Bluemustnag22 Posts: 1 New Member
    Where you able to Figure this out because I have the exact same problem and have yet to figure it out.
  • Spud1954
    Spud1954 Posts: 4 New Member

    I'm afraid I didn't manage to 'get round it' Ogi and had to have the phone completely wiped at the Samsung service centre in Milton Keynes. I didn't reisnstall F-Secure on it and never had this issue again. and am still using the same phone. I don't know that it was definitely due to F-secure but think it probably was. The service centre said it is the only type of software that could completely disable my phone like this.

  • janiS8
    janiS8 Posts: 2 New Member

    Hi Guys, any body got solutions for this. Even i am facing this issue.. i alos get message saying that.


    "Device Disabled. Contact IT administrator".


    Please do help me what to be done now.


    - Jani

  • janiS8
    janiS8 Posts: 2 New Member

    Hi , Even i get the same problem. please let me know is there any thing i can do to save all my data in phone with out wiping completely.



This discussion has been closed.
Pricing & Product Info