FS Protection PC Release 215

New Features:

Browsing Protection:

  • Banking Protection uses referer history to allow returning to unrated web store after payment transaction. This requires the transaction flow to have the referer info set, though, so it will not solve all unrated web store problems. (PBL-3070)

Fixed issues:

Common:

  • Event history links don't work always
  • Some events are not updated when they should
  • No flyer about product update
  • Privacy policy link in Common Settings leads to empty help page
  • Update server address in Common Settings has "http://" prefix

Antivirus:

  • Riskware flyer button text wrong (PBL-3471)
  • Notification details icon is too big compared to main UI (PBL-3469)
  • Application allowed flyer broken (PBL-3455)
  • OAS Harmful File/Application blocked events have no details (PBL-3454)
  • OAS UA removed/restart required event has wrong text (PBL-3452)
  • Maybe space after "location/reason" keywords of Toasts (SAFE_BUG-02358, PBL-3450)
  • About box contains htmlgui resources twice (PBL-3445)
  • DeepGuard (also ransomware) event empty (PBL-3433)
  • "Protection is very old" missing flyer (PBL-3432)
  • "Malfunction" event missing (PBL-3429)
  • "Malfunction flyer missing (PBL-3428)
  • "Protection is not up to date" event missing (PBL-3427)
  • "Manual virus scan could not handle some harmful items" event missing (PBL-3424)
  • Toast do not use "location/reason" keywords (SAFE-BUG-02343, PBL-3409)
  • Toast with not fully visible string (SAFE-BUG-02342, PBL-3407)
  • Main GUI wording unclear when virus protection disabled (PBL-3335)

Browsing Protection:

  • Bing search result icon issues with localized Bing (PBL-3449, SAFE_BUG-02356)

Answers

  • SimonSimon Posts: 2,560

    All seems fine.  Can't really find anything to comment on.

     

    Although, seeing as we had a winter theme earlier, how about a summery theme now?

  • alampalamp Posts: 2

    捕获.PNGSeems still have some problems in the event history area, there are somethings that are not shown as in the picture above.

  • nanonymenanonyme Posts: 143

    That's probably malware detection localizations that are missing.

  • Lord_AmiLord_Ami Posts: 68

    Upgrade went as smooth as ever.

     

    Still - the Allow button is missing in DeepGuard detections. Is it explicitly configured like that?

  • UkkoUkko Posts: 2,893

    Hello,

    Spoiler

    Looks like that with one of my systems (but it is only one system where I check situation yet) after three potential 'visible' system changes like:

    -> installed recent monthly Windows Update;

    -> installed CCF 3.15.225;

    -> installed Antivirus 17.215.129;

    with restart system after each event.

    Start be next potential trouble:

     

    >>> Received toast from FS Protection (for example, soon time limits; scheduled scan is start; detected malicious item is blocked) and it is visible.

    >>> Toast is not read (system is idle, for example).

    >>> System (Windows 10) with visible count of missed notifications (Notification area logo). For example, three items or one item.

    >>> Choose such place to look what is it (which one toast/event) -> and there is empty screen (no fresh notifications).

     

    Does it only my local experience or some of noted changes are valid for all (as reason for such situation with inability to look for 'missed' toasts)?

    // later edited: sounds that situation (from spoiler) is pinned to something with my system. because situation is valid for system toasts too. Sorry for reply.

    // one more update: later I found that there was activated (ON) Windows Defender with FS Protection at one time. Because I received a toast about Windows Defender own Protected Folders feature (which was introduced with recent system update and was ON as default) during opening scan log report by FS Protection. I decided to look for Windows 10 Security Center and found that Windows Defender is enabled/activated with all features. I decided to restart system else one time -> and all previous toasts are back to notification area (and was visible with limitation of twenty ones for each day/process).  Both system and FS Protection 'missed/unread' toasts.

     

    Thanks!

  • Lord_AmiLord_Ami Posts: 68

    There seems to be serious memory leak. See my 

    SAFE_BUG-02373
     
     
    Happens when I start uploading large files to Jottacloud. Memory usage is going up till 95% (I got 12GB of RAM) and uploading fails. With FS Protection disabled, everything is fine.
  • yeoldfartyeoldfart Posts: 506

    Hello

    this is due to F-S annalyzing files on the fly.

  • Lord_AmiLord_Ami Posts: 68

    It's one possibility, but I've never had such experience before. So there must be something bugged in FS.

  • yeoldfartyeoldfart Posts: 506

    Is there any other anti malware tool in the background ?

  • nanonymenanonyme Posts: 143

    @Lord_Ami wrote:

    There seems to be serious memory leak. See my 

    SAFE_BUG-02373
     
     
    Happens when I start uploading large files to Jottacloud. Memory usage is going up till 95% (I got 12GB of RAM) and uploading fails. With FS Protection disabled, everything is fine.

    Hey,

    out of curiosity, how large is large in this case? What kind of file format are we talking about? Does this upload work through browser (and as such possibly subject to the browser plugin) or is this a native application?

  • Lord_AmiLord_Ami Posts: 68

    It's about 2GB file. I have not specifically tested with e.g 100MB, 500MB and 1GB files to see where this behavior is triggered.

     

    I'm using Jottacloud native program for Windows. Same setup as I've always used, just FS is updated in between.

    I'm pretty confident it's either FS issue or some conflict with other app. Since I've also included fsdiag.zip, I hope to hear back from devs privately :)

  • UkkoUkko Posts: 2,893

    Hello,

     

    I am also using Jottacloud with some systems.. but funny to write -> practically do not upload anything. :)

    Does your experience with memory usage is by Jottacloud process?

     

    Recently, I received 'stuck' (?) with fshoster and its stable drive-usage for something (unusual, uncommon) stable and some hours until restart (it was CPU and drive-usage). I suspect 'clean'-process which was before such stuck (detected item at "drive:\malicious_item.extension"); But I did not repeat it manually later.

  • yeoldfartyeoldfart Posts: 506

    updated my rig to W10 april: F-S as fine as before

  • VilleVille Posts: 477

    Hello beta testers,

     

    We are working on some bigger changes for the installer at the moment, so there will not be any beta releases before June.

     

    Ville

    (F-Secure R&D)

     

  • Lord_AmiLord_Ami Posts: 68

    Hello!

     

    Any news regarding new beta :)?

  • yeoldfartyeoldfart Posts: 506

    our friend wrote "not be any beta releases before June" without precising the year  Smiley Tongue

    ... sorry for the bad joke, I could not resist the temptation.

    More seriously we are in june and still have one and a half week before june 30th.

  • UkkoUkko Posts: 2,893

    I smell the fresh TP (or is it something else? Smiley Indifferent)

  • VilleVille Posts: 477

    Hello @Lord_Ami @yeoldfart @Ukko

     

    Thank you for the interest. We have been working hard to stabilize all the new systems related to the changes (client and backend) but currently it's not ready and it will not happen during this week. We will still try to release it next week, but after that the vacation period starts and we lose the window of release. So.. we are close but it's hard to say if we will make it in June.

     

    (If we don't make it, I will use @yeoldfart's response as my defense Smiley Happy)

     

    Ville

    (F-Secure R&D)

     

This discussion has been closed.