Mac OS X 10.9.5 Firefox: F-Secure Safe Browsing protection Unsupported Legacy extensions

I do not seem to be able to use F-Secure Safe with Firefox on my Mac (OSX 10.9.5). I s there a solution?

Best Answer

This discussion has been closed.