F-secure stops using Roblox - "Initialization error 4"




It seems like F-secure is currently preventing my son from playing his favorite game - "Roblox". Upon start-up he receives the error message "Initialization error 4". Anyone having experienced the same or knows a workaround?


Very thankful for any guidance on this




  • whydoineedone
    whydoineedone Posts: 1 New Member

    thanks...you made me realise my issue was f - safe driven.

    I then turned off deepguard like this...https://www.youtube.com/watch?v=TBoYuNmwRiU

    Hope this helps...

  • Simon
    Simon Posts: 2,667 Superuser

    Firstly, does this still happen with F-Secure disabled?  Also, have you checked the Applications list to see if the game has been blocked?  If that's the case, there may be an option to Allow it.  


    If the above isn't relevent, or doesn't help, then you could submit the .exe file, or URL of the game to the F-Secure labs for analysis, and they will whitelist it if safe.


    Submit Sample

  • Ukko
    Ukko Posts: 3,641 Superuser



    Sorry for my reply. I'm also only F-Secure user (their home solutions).

    Anyone having experienced the same or knows a workaround?

    except feedback and suggestion under this topic - there was another one topic (recently): https://community.f-secure.com/t5/F-Secure-SAFE/F-Secure-Safe-for-PC-is-blocking/td-p/106133


    So, it is 'global' situation. And potential workarounds are allowing or excluding certain executable or folder. But fix is unclear (based on your words - situation is only started. and if so - maybe F-Secure Labs indeed with abilities to re-tweak situation; Except potential reason as upgrade/update of noted application with improving their own integrity/security checks and, as result,maybe more expected to receive their own potential tweaks to avoid such situations with security solutions).



    LSCTH Posts: 1 New Member

    Just had this issue on a friends PC


    Easy workaround


    1. OPen F-Secure

    2. Click on tools

    3. Click app and fiile control

    4. Click Excluded tab

    5. Click add new

    6. Look for roblox folder (c:\Users\*YOUR NAME* \appdata\local\roblox\versions\*Click on whatever folder you have in here*, then click on RobloxPlayerBeta

    7.Click ok


    This worked for me so hopefully will do for you



  • Luca_AcquireBPO
    Luca_AcquireBPO Posts: 1 Observer

    Looks like this is happening again.

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hello @Luca_AcquireBPO,


    Thanks for updating us about the issue and apologies for the delay in responding. Please get in touch with our labs through here so that they can investigate this further. If possible, kindly provide the fsdiag as well to the labs for the investigation.

  • MarkusB
    MarkusB Posts: 8 Explorer

    Roblox updates itself frequently. Due to poor programming every update changes the path of the execution file by renaming it according to the current version.


    You need manually change the path to your firewalll "bypass"-application list. Just copy paste the path from "properties". I take out the "-browser"- parameter also. 

  • Cale
    Cale Posts: 288 F-Secure Product Manager



    I just tryid the latest roblox and it ran without any problems. I have the latest F-Secure SAFE 17.6 installed. I didn't have to alter any settings or exclude the application.


    While investigating, I noticed that there are many reasons for the error and also other AV products cause it. Roblox has a page for this: https://en.help.roblox.com/hc/en-us/articles/203313030.


    F-Secure is missing from the list, but here's a link to submit the exe to us if you run into the same issue in the future: https://www.f-secure.com/en/web/labs_global/submit-a-sample#sample-file



This discussion has been closed.
Pricing & Product Info