Freedome blocks electronic bank deposits

LQGuy Posts: 6 Observer



I'm using Freedome VPN on an iOS device running iOS 11.2.6.  


When using my banking app to make electronic deposits, I am not able to upload an image of my check.  I receive an error message from the bank indicating a connection problem.  The only solution I have found is to delete the app from my phone in order to complete the transaction.  The same is true on my iPad, running the same iOS version and app.


The banking app is Capital One Bank.  I can access all areas of my account within the app.  I just can't get the deposit function to work.


Is there a way to have this work, without having to delete the app constantly?  I've tried shutting the VPN connection down in Settings, but it immediately reconnects (not a bad thing, except in this instance).


Thanks in advance for any assistance that can be provided!




  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi LQGuy,


    May I know if the deposit page opens directly in the app itself?


    Have you tried to turn off Freedome by clicking the ON button in the main page of the Freedome? Could you also try to turn OFF Tracking Protection or Browsing Protection one by one and check if the issue reoccurs?


This discussion has been closed.
Product & Pricing Info