F-secure SAFE - no internet connection

Hi guys,

 

I cant finish my F-secure Safe setup. It keep sending message "No internet connection". But internet is working just fine.

I am using Windows 10, and Windows diffender is off.

Any tips please?

Comments

  • UkkoUkko Posts: 2,999 Superuser

    Hello,

     

    Maybe it is good to know -> which step will trigger such notification.

    For example, from first (at launch installer) or during latest steps of installation.

     

    Also, good to re-check that there is not installed any third-party firewalls or some other security software with abilities to prevent/block/filter network connections. For example, some of F-Secure domains or URLs.

    Also, good to re-check potential points about system proxy configuration. But, probably, installer should handle it normally.

     

    Thanks!

  • It happened during latest steps of installation. At the end of proccesss window appers "F-secure setup" with notification "No internet connection. Could not connect to the server..."

    So basically I cant finish installation process. I tried couple of times, but still the same.

     

    I dont have 3rd party firewalls installed. All anti-virus programs are unistalled.

    Proxy settings are on "No proxy" (Mozzila).

  • It happened during the installation process.

    At the end of installation window appears "F-secure setup", but with notification "No internet connection. Could not connect to the server..." (PrtSc attached)Picture1.jpg

     

    Proxy is off, and no other firewall applications are intalled on PC.

  • UkkoUkko Posts: 2,999 Superuser

    Hello,

     

    So, maybe there are some internal troubles with F-Secure servers. And with try to retrieve license information or load "Login page" (if your installer with view like "NetworkInstaller.exe" and not like "NetworkInstaller_bundled_licence_key.exe").

     

    For example, there is such topic today:

    https://community.f-secure.com/t5/F-Secure-SAFE/Proxy-Error-Message/td-p/104750

    And I also got the 'troubleview with portal' during try to use it (one-time) some minutes before.

     

    I feel that it is OK to contact direct F-Secure Support Channels (chat or phone):

    https://www.f-secure.com/en/web/home_global/contact-support

     

    Otherwise -> I will try to install F-Secure SAFE on my own device as clean installation and to see if there is global trouble. But I'm also only F-Secure user (their home solutions) -> so.. it maybe not so useful to receive my suggestions when it is possible to ask Support Agents.

     

    But just like clarification ask: did you see "small loader window" and then such view?

    Or "small loader window" is switched to "large Welcome window" where was buttons like "Install it/Start" and its switched to noted trouble window?

     

    Thanks!

     

    // with my tries was possible to perform installation (looks like). So, maybe there are some local reasons for such situation and likely that Support Agents with abilities to re-check it with certified steps.

     

  • I saw "small loader window" and then this view. Installation seamed ok till this last screen appeared.

     

    I will contact support directly.

    Tnx for the help.

    Ukko
This discussion has been closed.