Connection to certain websites programs closes, only way to fix is shut down f-secure



For a couple of days now i have been having a problem where my connection randomly drops to certain programms/websites. For examle and are both unreachable then. Chrome gives error ERR_SSL_PROTOCOL_ERROR, my discord client also disconects. Restarting my pc temporarily fixes the problem. The only way permanently to fix is disabling all anti-virus actions in f-secure. I checked and just disabling windows firewall doesn't fix it. Anybody know what's going on?


Windows build: 16299.192

F-secure version: F-Secure Aquarius Update 2018-02-02_04


Thanks in advance 


  • Ukko
    Ukko Posts: 3,561 Superuser



    Sounds that it may be F-Secure Content Blocker (Parental Control) feature. For example, if there are chosen some categories like "social media". AND F-Secure Browsing Protection addon is disabled. AND page is accessed as HTTPS.

    But... it is unclear why restart will fix it. If you did not mean that only for some first minutes, of course.


    Does it possible to re-check such URLs with another browser? Internet Explorer as example; Or Microsoft Edge.

    Also, does it F-Secure SAFE or F-Secure Internet Security?


  • Mas_
    Mas_ Posts: 3 New Member

    The restarting fixes it for a variable amount of time, from a couple of min to an hour or so. Where would i find the content blocker settings, i am the only user of this machine so i haven't set any of these restrictions myself.

  • Mas_
    Mas_ Posts: 3 New Member

    I have F-secure safe*

  • Ukko
    Ukko Posts: 3,561 Superuser


    I have F-secure safe*

    I'm also only F-Secure user (their home solutions). So, sorry for my only unofficial suggestions.


    With F-Secure SAFE it should be possible to fix/re-check with steps like:


    ->> Login into My F-Secure Account portal (

    ->> Choose your device installation (or circle);

    ->> Choose button like "Parental Control"; Then "Content Blocker" (or so);

    ->> If it is enabled -> possible to re-check that there are only expected categories. And remove some of them like 'social media'.


    // later edited -> did not notice your first reply; so, it will be generic advice -> but when enabled "Content Blocker" is not expected  -> should be possible to disable it at all.

    If it was enabled and all categories are expected (included 'social media') -> so, good to re-check that your Google Chrome with enabled (or installed) F-Secure Browsing Protection extension;

    For example, by such steps:


    When Browsing Protection addon is enabled -> most likely, with opening noted pages -> will be visible F-Secure Blockpage with description about reasons. Then -> it should be possible to "Allow website" (if it is valid for you).


    If your experience not about such reasons -> sorry for my suggestions.

    Also, sorry for my worst English.

    Do you able to try some of suggestions and back with results about?



This discussion has been closed.
Pricing & Product Info