How to setup Overwatch and F-Secure SAFE

Hi,

 

The game is installed and works fine (= finds the game server) only if I disable all security F-Secure SAFE settings. It is not enough to disable individually the different protection components but I have to disable EVERYTHING.

 

There are some instructurictions from Blizzard (the author of Overwatch) and I have tried to allow certain TCP and UDP ports (https://us.battle.net/support/en/article/7842). No success.

 

 

Is there any convenient way to enable Overwatch network traffic and keep the security services active?

 

Thanks!

Markus

Comments

  • UkkoUkko Posts: 2,999 Superuser

    Hello,

     

    Sorry for my reply. I'm only F-Secure user (their home solutions).

     

    It is unclear why only "disable all security settings" (but... by what steps?) did the trick.

    With my feelings -> should be certain option (OR maybe multiple of them as different layers with this certain situation).

     

    Potentially -> such view can be related with own 'integrity/security' application design. And, for example, something goes wrong (based on F-Secure analysing, scanning, hooking).  Maybe possible to re-check such meanings with steps like: add certain executable (or game-folder) to Real-time scanning exclusion list. And then re-check does it helpful or not.

    If yes -> maybe good to re-check this Knowledgebase-article:

    https://community.f-secure.com/t5/Common-topics/Recommendations-regarding/ta-p/102377

     

    Another potential troublepoint -> if certain domain (URL) is marked as harmful (or restricted content). One of game-CDNs or so. But with such situation -> should be enough to disable Browsing Protection module.

     

    And report situation to F-Secure Labs (F-Secure SAS):

    https://www.f-secure.com/en/web/labs_global/inform-us

     

    Thanks!

     

    // as example, another example of trouble with games:

    https://community.f-secure.com/t5/F-Secure-SAFE/F-Secure-Deep-Guard-blocks-PES/m-p/101462

    Näsäviisasmakebymake
This discussion has been closed.