Freedom fails to open after todays update ... 1.08.18

I downloaded the latest update to my Macpro and now the App fails to open. Help

Comments

  • LakshLaksh Posts: 4,432 Community Manager

    Hi Jhansi,

     

    May I know what is the OS version of your Mac?

     

    Did the installation complete on your Mac? Was there any error message when you tried to open the application?

  • Hi Laksh,

     

    My Macbook Pro with macOS 10.13.2 has the same issue, Freedome is not running at background when restart, also not opening when tried to click it from applications. No error message, and no respond / icon shown at the dock. Have tried to re-install twice but still the same. Thanks for help!

  • JhansiJhansi Posts: 3

    I am using OS version 10.11.6 (el Capitan). After the down load and double clicking the app it failed to open. The sustem did tell me Freedome was running. I forced quit, double clicked and it again told me it was running but there was no open screen.

     

    I have to say that initially I did get the usual open screen but then for some reason it would not appear any more. Because there was no opening screen I could not "do" anything. 

     

    After some time I realized I could restore the old version from time machine. I did and it installed perfectly and it now is running just fine. So I continue to run this old version of Freedome for protection.

     

    jhansie

  • LakshLaksh Posts: 4,432 Community Manager

    Hi AnthonyK,

     

    If the issue persists, kindly get in touch with our support team via chat or phone here in order to troubleshoot this further. We might need the logs for further investigation.

This discussion has been closed.