Freedome needs long time for connection and stop connection since last update

Yes, what should I say, it's written in the topic. Before Freedome worked fine, but since the last update 2, 3 weeks ago it needs 3, 4 minutes to connect (doesn't matter which server), and also needs 3, 4 minutes to stop the vpn connection. Before Freedome connected within seconds. I tried to uninstall Freedome and reinstall, but it didn't helped. I didn't changed anything else on my computer, so it must be a problem of the last Freedome update.

 

I use Win 10 64.

Answers

  • BenBen Posts: 2,640

    Hello HanDuo,

     

    We have received some reports of this type of behavior and prepared some improvements. 


  • Fsc123Fsc123 Posts: 2

    Have you edited your hosts file? In my case the problem was related to a large hosts file and DNS. Seems a large hosts file (50k entries to block ads) started confusing Windows DNS and Freedome kept waiting for DNS for several minutes. I also noticed "DNS cache timeout" errors in Windows logs.

     

    Solution was to restore the Windows default hosts file (after which Freedome connection was established in 10 seconds or so).

     

    The hosts file is located at:

    \Windows\System32\drivers\etc\hosts

This discussion has been closed.