Freedome Crash when hit the "Protection ON" button

After todays software update of Freedome VPN the program fails when I hit the protection on button. The message says: "Error - Something wnt wrong. We are sorry"

I have no idea why and what do to do to fix this issue. Ive tried to reboot computer, remove and reinstall software but with no difference. Where can I download old software? How to fix this issue? When will F-secure push an softwareupdat adressing this issue??

Ukko

Best Answer

  • attaatta Posts: 13
    Accepted Answer

    Finally fixed. The trick for me was to do these steps as suggested from F-secure support:

     

     

    Open a Command Prompt window (Run as administrator).

       

    1. Run pnputil -e >list.txt  which creates list.txt and you can easily search "f-secure" from that text file.  
    2. Figure out which .inf file is associated with the F-Secure Freedome TAP driver  
    3. Run pnputil.exe -d oem<NUMBER>.inf  Which will remove the driver.  
    4. Restart the computer.  
    5. Reinstall Freedome   Please send us fresh FSDIAG if the issue still perisist. 

     

     

     

    UkkoLaksh

Comments

  • UkkoUkko Posts: 2,997 Superuser

    Hello,

     

    Just as my own feedback (I'm also only F-Secure user):

     

    --> with my experience Freedome still work after update;

     

    --> but looks like that there is global trouble:

    https://community.f-secure.com/t5/F-Secure/Update-from-Freedome-v1-2-to-2-4/td-p/102144


    One of knowledgebase articles about next points:

    https://community.f-secure.com/t5/F-Secure/Freedome-for-Windows-requests/ta-p/77951

    another noted topic with information that reinstallation for Freedome will trigger multiple TAPDrivers. Maybe possible to re-check such meanings and check -> if FreedomeTAPDriver is listed under network adapters, that it's active and with good properties.

    Possible that such trouble based on certain system security configuration and requirements for such drivers.

     

    Maybe possible to contact direct F-Secure Support channels (chat as example):

    https://www.f-secure.com/en/web/home_global/contact-support

    potentially it should to boost up situation, but maybe not required and any official F-Secure Staff with abilities to perform own research and investigation (or if someone already did ask Support about situation).

     

    Thanks!

  • LakshLaksh Posts: 4,432 Community Manager

    Hi atta,

     

    May I get the following information in order to further narrow down?

     

    1. What is the OS of the device in which you see this error?

    2. Did the error pop up after an upgrade? Or out of a sudden?

    3. Was Freedome working normally before this without any error?

    4. What is the current version of Freedome installed on the device?

  • attaatta Posts: 13

    Hei

    Answers to your questions😊

    1. Windows 10

    2. The error happened stright after a software update of Freedome VPN. And I get the error message after everytime I try to activate protection. And the protection shuts off.

    3. Freedome worked flawless before

    4. I will chech later. But it automaticly upgraded to the latest version

    DavidG67
  • attaatta Posts: 13
    Will look into this, thx!😊
  • LakshLaksh Posts: 4,432 Community Manager

    Hi atta,

     

    Kindly get in touch with our support team here in order to investigate this further.

This discussion has been closed.