F-Secure blocks all Facebook tabs after Firefox update to v57


Having accepted an automatic update from v56 yesterday, I've found that each FB tab I have requires me to go back & forth cancelling internet banking. It wastes about 15 minutes every time I switch on.
What can I change to clear this.


  • Ukko
    Ukko Posts: 3,634 Superuser



    Sorry for my ask.


    Just as clarification before any advices -> does your experience about Mac-platform? 

    // if not... and your experience about Windows.

    Maybe possible to re-check that F-Secure Browsing Protection still enabled (or to trigger disable/enable addon). Because your description sounds like after update to Firefox 57 -> your F-Secure Browsing Protection addon/extension is disabled. As result: unexpected Banking Protection session is triggered.

    If this is not about your experience -> maybe good to add more information/view.

    If this is about your experience -> good to re-check that extension/addon with good state; And if so -> maybe possible to close/end Banking Protection session with closing it's flyer (?!).


    Sorry for my strange suggestions.



  • Ron11
    Ron11 Posts: 19 Observer

    Hello, sorry for delay in replying - I had a week without internet access - heaven or what?

    I'm using W10 and F-Secure was operational all the time. What I found was that after at least six attempts at opening each tab, it finally realised that I wanted it functional. The most repetition was with Facebook, where each tab took at least 10 attempts to open the page.


    Having now returned to the real World, I'm very pleased to report that all my tabs are still working without interference from F-Secure.

This discussion has been closed.
Pricing & Product Info