PROBLEM renewing SAFE which has expired on to iPad (virgin media renewal)

Just realised my F-Secure had expired and tried to renew by hitting renew now &continue but it just keeps taking me through to blank white screen with a message bar across the top saying it was F-Secure on the left hand side of the screen and shopping cart on the right side but nothing then happens.  It won’t open shopping cart or anything.  Tried calling them but it says their offices are closed Saturday and Sunday which is no good if something goes wrong over the weekend like this.  Any ideas what I should do?

Best Answer

  • SimonSimon Posts: 2,583
    Accepted Answer

    Which browser are you using, and have you tried a different one?  I use SeaMonkey and have had problems with My F-Secure using that, but it works in Firefox and IE.   

Answers

  • Thanks Simon that definitely worked.  My default browser was google and I changed it and it work so I’m all secure again.  Thank you again.

     

    Ukko
  • SimonSimon Posts: 2,583

    Cool!  Good to hear.  

This discussion has been closed.