Ancestry reated as Internet banking?

Hi today I got some odd problems while using Ancestry in my genealogical research. When I have Ancestry active I cannot use google as I want. A lot of pages are blocked due to "banking session". Even after turning banking protection off. I have also tried to empty cache and restarting myc computer.

I have scanned my computer and F-Secure did not find any virus or malware.

I use F-Secure SAFE 17.0 Common Component Framework 2.93 build 173. My browser is Firefix 56.0.2 (64 bits). My computer is a Sony Vaio with Windows 10.

I upgraded my license 2017-10-19. Could there be a reson for my Problems with F-Secure SAFE?





  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi Stizze,


    Did you face this issue with Ancestry before? Also, just to confirm, is this an application?

    Did you still have the same issue even after restarting the computer? Please try to restart your computer and recheck the issue.



  • is a genealogical forum and database for genealogical research where I have a member login account. I have the same problem today and I got the same block due to "banking session" and I have still banking protection  set to off since last weekend. It seems that all https-pages get "safe connection" and I think these pages are treated as "banking session".  I.e right now this Page has a "safe connecion" and right now I cannot reach http-pages. Only if there is a https-version available.

    Same result when I use Chrome  61.0.3163.100. Edge is even worse. I get  Kan inte ansluta till sidan på ett säkert sätt when i try to reach 

    I do not get the banner which informs me that "banking session" is active. I only get the whole page where I can make an exception to allow the web page but it is still blocket.

    When I check in F-Secure SAFE in the list of exception the page is registered there.

    I got a feeling that some parts of my old version of F-Secure SAFE is still running. I did uninstall it before I installed the new version.




  • I did not have this problem before I upgraded and some time afte the upgrade. I did use Ancestry without problems togehter with non-https pages. The problem seems to get more frequent the last days and virus scans does not detect anything.

  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi Stizze,


    If you suspect the ancestry webpage is marked wrongly as a Banking page, please submit the URL to our labs for analysis. You can submit it via here.

    Please tick 'I want to give more details about this sample and to be notified of the analysis results' and submit your information.


  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Thanks for the update, Stizze. Glad to know all ok now.

This discussion has been closed.
Pricing & Product Info