Can't install f-secure

Hi.

I have been using Internet Security for some years now, without any problems. Suddenly one day I received a message in windows 7 action center that I had to activate F-secure. I klicked it and nothong happened. I couldn't open F-secure at all, so I uninstalled it. I downloaded f-secure SAFE trial (free), and tried to install it. Then I received a message that it can't be installed because it's not compatible with 64 bit windows. I have also tried to install my old f-secure internet security with the same result? So now I have no protection at all. What can I do??

Katarina

Best Answer

  • WiipaWiipa Posts: 2
    Accepted Answer

    I found a solution to this.

    I ran the uninstallation tool, and now I can install f-secure! Thanks for reply!

    Ukko

Comments

  • UkkoUkko Posts: 2,997 Superuser

    Hello,

     

    Sorry for my ask.

     

    Does your experience about official installers from F-Secure websites/pages?

    Like this ones:

    https://www.f-secure.com/en/web/home_global/downloads

     

    Or maybe possible to add screenshot about such notification (about compatibility-state)? Or more description for it? Probably sounds as something wrong with system or installer-files (like something do block it as another security solutions; Or something else, but good to know - if other files are launched good).

     

    Thanks!

This discussion has been closed.