I have renewed my F-Secure subscription but the product remains expired Symptoms
F-Secure product subscription remains expired even after you purchase a renewal.
Diagnosis
There may be a number of reasons as to why the product remains expired.
- Product/subscription mismatch
You might have selected a different F-Secure product from the one that you originally purchased when the renewal was made.
- The product has not synchronized with the subscription server
If you have just recently renewed your F-Secure subscription, it is possible that the product has not queried the subscription server yet.
- Problem with subscription database
It is possible that during the renewal process, your subscription database has become corrupt.
Solution
Product/subscription mismatch
Verify that the product installed on your computer matches the product that you have subscribed to.
Check the product installed on your computer:
- Right-click the product icon from the taskbar.
- Click About....
- Verify the F-Secure product name that is displayed on screen.
Check the product available to you in My F-Secure:
- Log in to My F-Secure.
- Select Subscription from the top navigation pane.
- Under Overview, verify the F-Secure product name.
If the product names do not match, uninstall the product from your computer and install the product from My F-Secure.
Product has not synchronized with the subscription server
Perform a manual update on the product installed on your computer:
- Right-click the product icon from the taskbar.
- From the menu that opens, select Check for updates.
- Under Connection, select Check now.
Problem with subscription database
If your subscription issue still persists, try reinstalling the product from My F-Secure, or contact support.