WhatsApp on Android 7.0

Aspirant

WhatsApp on Android 7.0

Hello,

 

I'm evaluating FREEDOME VPN on my Nexus 6 with Android  7.0.

All good so far but I noticed that WhatsApp after a while does not receive or send any messages anymore.

Before to add it to the excluded applications do you have any suggestions?

Could this be related to something similar to this article?

 

https://community.f-secure.com/t5/F-Secure/Freedome-and-Whatsapp/td-p/80512

 

I know that the article is about iOS but do you think that Android has a similar mechanism?

In the Android VPN configuration, I found the following option that for FREEDOME VPN is actually turned off: Always-on VPN.

 

Do you advise to turn it on and what are the implications?  

 Kind regards,

Marco - StockTrader 

1 ACCEPTED SOLUTION

Accepted Solutions
Aspirant

Viite: WhatsApp on Android 7.0

Hi,

 

I excluded WhatsApp from the VPN. Problem solved.

Thanks for your additional info.

Of course, you need online connection for WhatsApp: that is clear Smiley Happy 

I use your VPN for 4G and Wifi.

 

 Regards,

Marco - StockTrader

View solution in original post

5 REPLIES 5
Superuser

Viite: WhatsApp on Android 7.0

Hello Marco

I was searhing more info about WHATSAPP-problem and I found this netpage
www.whatsapp.com, then troubleshooting and finally connection problems.

There is many reasons, why connection does not work.

Is it so in Nexus that Freedom is not ON all the time?

What about phones textmails?
Any problem?
And possibly emails?

With this message
NÄSÄVIISAS


Aspirant

Viite: WhatsApp on Android 7.0

Hello,

 

the VPN is ON all the time, the emails are working perfectly in and out.

The option iVPN ALWAYS ON is set OFF by default in the Android 7,0 system.

 Kind regards,

Marco - StockTrader

Superuser

Viite: WhatsApp on Android 7.0

More info

I was looking for more info about Android7-operationsystem.

A new feature is DOZE-batterysaving property.
It means DATA SAVER.

Open settings
Data usage
Data saver to enable: check this

In that earlier article (WHATSAPP.COM)
was mentioned that:
Keep vpn on, when device is idle,
setting to configure Freedom to keep
the vpn connection always open.

Note that this have some effect on the battery consumption.

More info of the same article, connection problems:
Settings
Data usage
Cellular data is turned on

Settings
Apps
Whatsapp
Data usage and sure background is not restricted

Make sure WI-FI stays on during sleep mode.

Reboot your WI-FI router.

If use WHATSAPP on WI-FI
but not on data connection,
check configuration,
send and receive non-web traffic.

Summa summarum:
is it so, that this batterysaving feature effects on Whatsapp?

Not so simple!
NÄSÄVIISAS



Superuser

Viite: WhatsApp on Android 7.0

One more point:

In order to work wright, Whatsapp needs on line connecton.

The same kind of problems (Whatsapp/Android7) I faced when searching info via Google.

NÄSÄVIISAS
Aspirant

Viite: WhatsApp on Android 7.0

Hi,

 

I excluded WhatsApp from the VPN. Problem solved.

Thanks for your additional info.

Of course, you need online connection for WhatsApp: that is clear Smiley Happy 

I use your VPN for 4G and Wifi.

 

 Regards,

Marco - StockTrader

View solution in original post