cancel
Showing results for 
Search instead for 
Did you mean: 

Freedome won't connect to any location (Windows 7)

Highlighted
Novice

Freedome won't connect to any location (Windows 7)

Hello there. So I am a bit at loss here. I've had Freedome for about a month now and it has been working just fine up until a few days ago when it just stopped connecting to any location. It will just stay in the "connecting" stage for forever. I've tried all kinds of locations so it shouldn't be a problem with the location, right?

I have Windows 7, no other VPN installed. I've turned my laptop on and off again several times since the problem started.

My best bet is, it has to do with the  router/WiFi? I've been in a different network for the past few days.

I couldn't find any solution on the forums already so I thought I'd try my luck with posting.

Thanks in advance!

1 REPLY
Community Manager

Re: Freedome won't connect to any location (Windows 7)

Hi gretagulny,

 

Could you try to connect to a different Wi-Fi and check if it is possible to turn on Freedome?

 

Are you facing this connection issue with any other device apart from the Windows 7?

 

Please have a look at this article as well regarding the port configuration for Freedome on Windows.

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.