Freedom (running windows 10) disables internet

Aspirant

Freedom (running windows 10) disables internet

Hi,

seems to be difficult to get except of calling direct support from F-Secure (payed product though).

I have searched via google and found only similar and old posts.

I am using Freedom here and there and now when I activate it, my WLAN adapter says it is disabled and I do not have any internet connection. 
Nothing changed, recently switched to WIN 10 but I thought that was working since I installed it.

Pretty useless application and not much of an info why it would be doing that.

Anyone an idea or a link to a solution?

Thanks and cheers... 

7 REPLIES 7
Moderator

Re: Freedom (running windows 10) disables internet

Helle @VoLe 

 

Thank you for reporting the issue, Freedome VPN supports windows 7 or later ( except Windows 10 running on Surface RT/ Windows 10 S). May I ask you to check the following steps?

 

1. Try disabling the Kill Switch feature on Freedome app. On Windows, the killswitch feature is turned OFF by default.   If you have enabled,  Open Freedome > Go to Settings > You'll see "use automatic killswitch to cut off internet connection if the VPN connection is disrupted" > Untick the box to disable the automatic killswitch.

 

2. If the issue remain, you can try check the ports are already added in your home WiFi router. Please refer this KB article to know more about port forwarding. You can also open this port checker website with your browser to check whether the open ports on your computer.

 

Aspirant

Re: Freedom (running windows 10) disables internet

Hello @Sethu 

I coming back to this issue after a very long time.

To #1 No the killswitch was not activated.

To #2 As mentioned, I switched the PC and operating system. But my router, my WLAN, all stayed the same. Why I would need to change something when it works with my other devices? 

 

If I activate Freedom protection it cuts all network connections on my new device. So it is rather a setting in between Freedom and the device firewall? I have no logs and I am not sure e.g. what I could check with the ipconfig command here to understand what the root cause might be.

 

Thanks and best regards,

Volker

Moderator

Re: Freedom (running windows 10) disables internet

Hello @VoLe 

 

We have had received similar cases and most of the time it can be fixed using the basic troubleshoot techniques. Please try the following steps to see if that solve the issue.

 

On your windows machine, Open the command prompt as an administrator and type the following commands:

 

 ipconfig /flushdns
 netsh winsock reset
 netsh int ipv6 reset

 

You can now check the Freedome again. If the issue still reproduce, you can try re-install the Freedome again.


 Uninstall F-Secure FREEDOME from the affected device.
 Restart/reboot the device.
 Reinstall F-Secure FREEDOME.

 

If none of the above solve the issue, may I know the brand name of your desktop machine? i.e HP or dell

 

Would it be possible for you to check if you are able to connect to internet while using Freedome VPN on LAN cable connection instead of WiFi ?

 

Aspirant

Re: Freedom (running windows 10) disables internet

Hello,

I have done all the steps provide, the first ones and re-installation. The problem remains on my HP notebook.

Best regards,

Moderator

Re: Freedom (running windows 10) disables internet

Hello @VoLe 

 

Thank you once again for your continued co-operation,  I doubt that this happens because of HP's automatic utility  i.e LAN/WLAN/WWAN switching function, which closes the Wifi connection if an ethernet connection is active. When using VPN software, the virtual TAP Driver in Windows triggers closing of Wifi connections, which then cuts the connection the virtual LAN communicates over. 

 

First, try manually disabling WWAN through HP Connection Manager, which should help with VPN problems, according to this HP article.

 

You can also have a look at this article where some instructions on how to disable theat VPN jamming service( by OlliOlsn) or you can just try the following instruction. 

 

Deactivate HP LAN/WLAN/WWAN Switching UWP Service. Depending on laptop model, this might also be called LanWlanSwitchingService. The service can be disabled seperately every time you use VPN or permanently (starting automatically by default).

 

How to deactivate:


1. Press [Windows] + [R]
2. Type in services.msc and Enter
3. Look for HP LAN/WLAN/WWAN Switching UWP Service or LanWlanSwitchingService
4. Right click and select Properties
5. Look for Startup type and choose Disabled from the dropdown menu
6. Reboot computer

Aspirant

Re: Freedom (running windows 10) disables internet

Hello @Sethu,
I have done as instructed, have tried all. 
I do not understand how a consumer product does not work by default.
What report to deliver that you can check what is going wrong?
Some settings must prevent F-Secure product to work properly.

 

Moderator

Re: Freedom (running windows 10) disables internet

Hello @VoLe 

 

Since you have performed all the basic troubleshoot steps for the internet blocking issue. Next course is we need to analyse the logfile to identify which F-Secure components are blocking by Freedome. For the, please contact our F-Secure Support for further investigation.