F-Secure no longer works on my iPhone 7S. Need to turn it off for EVERYTHING.

Highlighted
Scholar

F-Secure no longer works on my iPhone 7S. Need to turn it off for EVERYTHING.

For some reason F-Secure stopped working on everything on my cell phone.  I have to turn it off to access the internet, my bank & even opening apps I already have on my phone.  What am I paying for if I have to keep it off.

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Re: F-Secure no longer works on my iPhone 7S. Need to turn it off for EVERYTHING.

Hi @LaurieS 

 

Could you please try to perform a network reset on your iPhone and configure Mac DNS server address. I have provided detailed steps below;

 

To Reset Network Settings on your iPhone

- From your iPhone homepage, click on Settings

- In the Settings page, click General 

- In the General page, click on Reset

- then click Reset Network Settings (be cautious not to click on any other reset)

Once done, try to rejoin your network and enter your Wifi password, then try again. Ensure you change the VPN servers to 2 - 3 others and see if that solves the issue. 

If issue persists, try another wifi or mobile hotspots.

 

 

On the Mac, manually configuring your Mac computer with other DNS server addresses can help you;

- From the Apple menu, select System Preferences

- In the System Preferences window, click on Network

- In the left-hand navigation bar, select the connection through which you connect to the internet and click Advanced.

- Select the DNS tab. Then, under DNS Servers, select and remove (-) existing addresses. Finally, add (+) Google’s DNS server addresses:

8.8.8.8

8.8.4.4

 

it should look like this 

Mac.PNG

- Click OK and then click Apply

Restart your computer and try connecting again

 

If this fails, please try to connect to another network (internet) and let us know the outcome. 

 

4 REPLIES 4
Moderator

Re: F-Secure no longer works on my iPhone 7S. Need to turn it off for EVERYTHING.

Hi @LaurieS 

 

May I know the F-Secure Freedome version running on your iPhone? Have you tried to uninstall and re-install the Freedome app?

 

Kindly try deleting VPN configuration and turn ON again then see if this solves it.

 

You can also try to Enable the IKEv2 if the previous steps does not fix the issue.

 

To Remove VPN configuration on iOS:
- Open Freedome app
- Tap Settings
- Tap Remove VPN Configuration

 

To Use IKEv2 Protocol
- Open Freedome app
- Tap Settings
- Turn On the switch

 

Let us know if this fixes the internet issue on your iPhone caused by Freedome.

Scholar

Re: F-Secure no longer works on my iPhone 7S. Need to turn it off for EVERYTHING.

I'm using V2.8.10.6532.  I'll delete it & reinstall & see if that make a diff.  If not, I'll let you know.  Tanx.

Scholar

Re: F-Secure no longer works on my iPhone 7S. Need to turn it off for EVERYTHING.

My phone is running V2.8.10.6532

My MacBook Pro is running 2.27.5861.0

 

I removed it from both my comuputer & phone & I still can't use it.  Bummer.  What am I paying for.

Moderator

Re: F-Secure no longer works on my iPhone 7S. Need to turn it off for EVERYTHING.

Hi @LaurieS 

 

Could you please try to perform a network reset on your iPhone and configure Mac DNS server address. I have provided detailed steps below;

 

To Reset Network Settings on your iPhone

- From your iPhone homepage, click on Settings

- In the Settings page, click General 

- In the General page, click on Reset

- then click Reset Network Settings (be cautious not to click on any other reset)

Once done, try to rejoin your network and enter your Wifi password, then try again. Ensure you change the VPN servers to 2 - 3 others and see if that solves the issue. 

If issue persists, try another wifi or mobile hotspots.

 

 

On the Mac, manually configuring your Mac computer with other DNS server addresses can help you;

- From the Apple menu, select System Preferences

- In the System Preferences window, click on Network

- In the left-hand navigation bar, select the connection through which you connect to the internet and click Advanced.

- Select the DNS tab. Then, under DNS Servers, select and remove (-) existing addresses. Finally, add (+) Google’s DNS server addresses:

8.8.8.8

8.8.4.4

 

it should look like this 

Mac.PNG

- Click OK and then click Apply

Restart your computer and try connecting again

 

If this fails, please try to connect to another network (internet) and let us know the outcome.