Wireless printing issue

Highlighted
Scholar

Wireless printing issue

Hello,

 

I have a Canon PIXMA MP560 wireless printer which used to work fine until I recently installed F-Secure (not sure of where to find version #). I notice that if I disable the firewall it works as before and re-enabling the firewall stops the printer from being discovered.

 

I've read some suggestions on here and have created a HomeGroup rule to enable [MyNetwork] bi-directional access through the following services:

  • IGMP / Internet Group Management Protocol
  • Windows file sharing and network printers
  • Windows network browsing
  • SMB over TCP/IP (TCP)
  • SMB over TCP/IP (UDP)

This has resolved other issues regarding communicating with other network devices, but not when attempting to communicate with my printer.

I'm running Windows 7 (x64) if it makes any difference.

The printer is currently acquiring its IP from a DHCP server, but I think I can give it a static one if necessary.

 

Any suggestions on which other services or ports I need to enable to allow printing to work again?

 

Thanks,

Mike

1 ACCEPTED SOLUTION

Accepted Solutions
Former F-Secure Employee

Re: Wireless printing issue

Hi renMike,

 

If you are wondering which port / service need to be open in order for you to connect to the wireless printer, kindly create a logging firewall rule so that it will pop up the connection details (port number, IP, etc) when you are trying to establish the connection. You will be able to get the correct details to create a new firewall rule for the connection to your wireless printer.

 

1. Open F-Secure > Settings > Network connections > Firewall > Add
2. Name: Logging, Type: Allow > Next.
3. Any IP address > Next.
4. All IP Traffic (arrow point to both side)> Next.
5. Alert Type: Log and pop-up > Next > Finish.

6. Connect to your Wireless Printer and record down the details.

7. Create a new firewall rule based on that, and delete the Logging firewall rule.

 

Best regards,

Gary

 

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.

View solution in original post

7 REPLIES 7
Former F-Secure Employee

Re: Wireless printing issue

Hi renMike,

 

If you are wondering which port / service need to be open in order for you to connect to the wireless printer, kindly create a logging firewall rule so that it will pop up the connection details (port number, IP, etc) when you are trying to establish the connection. You will be able to get the correct details to create a new firewall rule for the connection to your wireless printer.

 

1. Open F-Secure > Settings > Network connections > Firewall > Add
2. Name: Logging, Type: Allow > Next.
3. Any IP address > Next.
4. All IP Traffic (arrow point to both side)> Next.
5. Alert Type: Log and pop-up > Next > Finish.

6. Connect to your Wireless Printer and record down the details.

7. Create a new firewall rule based on that, and delete the Logging firewall rule.

 

Best regards,

Gary

 

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.

View solution in original post

Scholar

Re: Wireless printing issue

Thanks Gary,


As a result of these instructions I found that my printer port was 51002. I was also surprised how much additional traffic was leaving my PC as a large number of messages were shown. Most seemed benign as they were to local addresses with services  I sort of recognised.

 

Having got my port number I then added a rule to allow traffic to that IP. During the rule addition I was surprised that no specific port could be entered, so I simply enabled bidirectional traffic to that IP. In short, I could have done that without the port number, but until I tried I didn't know.

 

I've since seen that there is an option for opening a firewall port from the 'Tasks' menu, but since it's working and it's only a printer at the other end I'll leave it with all ports open.

 

Thanks for your help, it did exactly what I thought I was looking for.

 

Mike

Scholar

Re: Wireless printing issue

Thanks, this is what I need too! I did Gary's steps 1-5 and I can now connect to the wireless printer and it works. Can you please give really simple, non-tech, advice what to exactly do in steps 6-7? It looks like I've created somekind of a generic rule in steps 1-5, but I now need to make it printer specifc.

F-Secure Product Expert

Re: Wireless printing issue

Hi Mmiika,

The "Log and Pop" firewall rule created in steps #1 - #5 is tend to allow all connections and it is for diagnostic purpose only.

Please note down the popups shown in step #6, it will shows what is the port number, protocol and/or services required for your wireless printer connections.

Step #7, create a new firewall rule based on the informations collected in step #6 then delete "Log and Pop" firewall rule created. Find this KB article for steps to create a new firewall rule for service not listed.

Hope this helps.

Thanks.


Best Regards,
Jayson

"A person who never made a mistake never tried anything new" -Albert Einstein

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Scholar

Re: Wireless printing issue

Thanks. What details exactly I need to collect in step #6? Number of protocols (igmp, udp etc.) are show after one another, each having different services like "IGMP out" and "restricted out". Each have differente local and remote addresses and remote and local ports. so, what of all this info I need to collect and fill in step #7?

What happens if I simply create rule with "any IP address", and "All IP traffic" (with both in and out arrows)? Printer works with that, but that is then open firewall for all other traffic too?

I also create rule with "custom IP address" and fed the one that the printer has (shown on LCD menu and also when printing a network report sheet) and "All IP traffic" (with both in and out arrows). Why does not that work?

 

THanks!

F-Secure Product Expert

Re: Wireless printing issue

Hi Miika,

I would suggest you to contact our Technical Support Team with all informations collected in step #6 and the FSDIAG, so we can take a closer look at this issue and help to configure the Firewall rule.

Thanks.


Best Regards,
Jayson

"A person who never made a mistake never tried anything new" -Albert Einstein

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Scholar

Re: Wireless printing issue

Thanks Jayson for your help,

 

tech support requested with link to this thread and the FSDIAG file submitted.